USB stick become read only after making a Mountain Lion install drive

Discussion in 'Mac Accessories' started by gsenroc, Dec 15, 2012.

  1. gsenroc macrumors newbie

    Joined:
    Dec 15, 2012
    #1
    Hi,

    I installed mountain lion some time ago, and used this tutorial to make the usb stick:

    http://osxdaily.com/2012/02/17/make-bootable-os-x-10-8-mountain-lion-usb-install-drive/

    I just forgot this stick for a few months after a successful installing. And today I want to use it and then I found this usb stick is READ ONLY...... I opened the Disk Utility and tried to erase it, but the erase button is gray and I'm not able to do anything with this usb stick. Tried to restore this stick with another DMG image, but Disk Utility failed to restore it. Also tried to delete the volume of the stick, yet failed.

    This stick is working fine just like a DVD, I can read the content without any problem, just can't write anything on it or delete anything, can't erase either.

    BTW, there is no "read only" switch on my usb stick.

    I've tried hard to google the solutions. There are many, but just haven't solved my problem. I hope I can find a solution here by posting, thanks in advance!
     
  2. harlie macrumors newbie

    Joined:
    Mar 25, 2013
    #2
    Same problem here. My USB-drive is a 8GB Verbatim stick.Couldn't find a solution to this problem either.
     
  3. SR45 macrumors 65832

    SR45

    Joined:
    Aug 17, 2011
    Location:
    Florida
    #3

Share This Page