USB stick doesn't show up?

Discussion in 'OS X Mountain Lion (10.8)' started by delwynnpawn, Mar 18, 2012.

  1. delwynnpawn, Mar 18, 2012
    Last edited: Mar 18, 2012

    delwynnpawn macrumors newbie


    Jun 12, 2011
    I am not sure if it's just the usb or is it a glitch in ML, but a usb flash drive that I am trying to access doesn't show up in my mac under ML. It doesn't show up in the desktop nor in any finder window. It does show up in Disk Utility, yet most commands associated with it are dimmed, only the eject one is available. Anyone having the same issue? :confused:

    p.s. I just tried it again on my other machine with lion and it does work. I verified and repaired it, no problems. Still, it just won't show up on ML, says can't mount.
  2. afin macrumors member


    Feb 17, 2012
    Clone it, Re-Format it.

    File a bug report if you still can't mount it.
  3. yearziro macrumors member


    Mar 31, 2009
    i had a similar issue with my memory card not showing up and i just rest the pram and smc and it worked like a charm maybe this will also help you

Share This Page