USB stick not mounting

Discussion in 'macOS' started by durija, Feb 28, 2008.

  1. durija macrumors 6502

    Joined:
    Jan 16, 2008
    Location:
    Seattle
    #1
    My USB stick (256MB Memorex) is randomly mounting or not when I plug it in and also when I restart. I never know when it is going to show up or not. I have tried formatting it as FAT and also as HFS. Same result either way. Running Leopard and I get the same result in 10.5.1 and also now 10.5.2. Oh, and it never recognizes it in the keyboard, only if I plug into the back or into my USB hub.

    If I take this exact stick to work and plug it into a Tiger OS iMac, all is well.

    Anybody else have this issue?
     
  2. Neil321 macrumors 68040

    Neil321

    Joined:
    Nov 6, 2007
    Location:
    Britain, Avatar Created By Bartelby
    #2
    Tried different ports?( sorry re-read post )
     
  3. Father Jack macrumors 68020

    Father Jack

    Joined:
    Jan 1, 2007
    Location:
    Ireland
  4. durija thread starter macrumors 6502

    Joined:
    Jan 16, 2008
    Location:
    Seattle
    #4
    Is it possible that nobody else has this problem?

    Does anyone have any idea what could be wrong?
     
  5. jazzyman macrumors newbie

    Joined:
    Feb 26, 2008
    #5
    I had the same problem.. I loaded it up into Windows and reformatted.. Then it all worked well.
     
  6. durija thread starter macrumors 6502

    Joined:
    Jan 16, 2008
    Location:
    Seattle
    #6
    Well, I already formatted it to FAT32 on the iMac. Maybe it will be different if I format it from a Windows machine? Seems odd, but I wil try it when I get home. Forgot to grab it today on my way out. Thanks for the response, jazzyman.
     

Share This Page