Usb stick problem

Discussion in 'Mac Accessories' started by cool11, Mar 7, 2012.

  1. cool11 macrumors 65816

    cool11

    Joined:
    Sep 3, 2006
    #1
    I have a 32gb Kingston usb stick(flash disk).
    I do not know why, but this stick does not seem to be 'compatible' with my mbp, osx-lion.
    When I want to eject it, several times I have to 'force-eject'. Not always though.
    Other times I try to empty the trash, with usb stick connected to mac, which means that the trash can has also usb stick deleted items, and my mbp crashes(halted - I have to restart mbp).
    I tried to format it, I used disk utility also, I formated in pc-windows as well, I tried so many different things. No convenient result.
    It seems that something is wrong and I do not know what it might be.

    I use other usb sticks with no problem.

    I use this stick in windows without problem.

    I have 'blueharvest' pane installed in my system.

    I cannot believe that this usb stick is faulty, because is Kingston, and I use so many Kingstons without problems. After all, if there was a problem with the stick, wouldn't it happen in windows machines too? But I use it in windows without problems.

    But something bad happen in this strange relation between my mac and this stick.

    Can you help me solve the problem?
     
  2. Ccrew macrumors 68020

    Joined:
    Feb 28, 2011
    #2
    I'll ask what may be obvious. Have you tried reformatting it in a different machine? Unsure by your post if you did it on another or in a bootcamp instance. I've seen issues where the FAT32 file system insists it's still in use although nothing in process monitor shows it and formatting on another machine cures it.
     
  3. cool11 thread starter macrumors 65816

    cool11

    Joined:
    Sep 3, 2006
    #3
    Yes, one of my efforts was to format it on a pc. But this does not cured the problem.
     

Share This Page