USB Stick won't show up on my desktop anymore

Discussion in 'Mac Basics and Help' started by slapdash, Mar 31, 2011.

  1. slapdash macrumors newbie

    Joined:
    Mar 31, 2011
    #1
    Hey

    I tried to put some files from my MacBook onto a PC using a USB-stick, but the PC didn't recognize the file system or something.
    When I tried to connect the USB-stick to my Mac again, it didn't show up on my desktop.. And I have no idea how to access the files on the stick now :(


    Any help please?

    Kind regards.
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    As a first step, with the stick connected, open up Disk Utility in the Utilities folder on the Mac, and see if the stick shows up in the list on the left. If it's not there at all, apparently it just broke, either because there was something wrong with the USB ports on the PC, or just coincidental bad luck. If it shows up there, see if it also has an indented volume listed underneath, and if that is showing as mounted or not (unmounted will be grey, mounted will be black).
     
  3. slapdash thread starter macrumors newbie

    Joined:
    Mar 31, 2011
    #3
    It shows up, and I guess it's not mounted?

    Here's a screenshot of the disk utilities:
    [​IMG]

    Is my data recoverable?

    Kind regards!
     
  4. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #4
    What happens if you select "NO NAME" and click the MOUNT button.
     
  5. slapdash thread starter macrumors newbie

    Joined:
    Mar 31, 2011
    #5
    Thank you for your quick reply!

    I selected NO NAME, but I'm wondering which function is the Mount function?
    My operating system is in Dutch :)

    [​IMG]

    Kind regards!
     
  6. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #6
    Sorry, didn't read the button texts in your screenshot.
    It is the button with "Activeer" written under it.
    [​IMG]
     
  7. slapdash thread starter macrumors newbie

    Joined:
    Mar 31, 2011
    #7
    Okay, that didn't work "Disk NO NAME" can not be activated.
    It says: Try again with Disk EHBO
     
  8. curtisinoc macrumors 6502

    Joined:
    Mar 13, 2011
    Location:
    Southern California
    #8
    Does a USB stick have to be formatted differently to work on Macs and PCs like external hdd do? (NTFS, FAT32, Mac OS extended...)? Or can a memory stick be used with PC and Mac without reformatting?
     
  9. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #9
    That's not a good sign; it sounds like the partition got corrupted. This could have been because the PC did something bad to it, in which case you might be able to recover the data by repairing it, and at least can keep using the stick by reformatting it. Or, it could have been a hardware failure (either by sheer coincidence, or because there's something wrong with the USB port on the PC), in which case it's toast.

    Try this: Click the greyed out volume, then click the "Repair" button in the "First Aid" tab (that would be "Herstel schijf" in the "Schijf-EHBO" tab. If you're lucky, it will get repaired, or at least you'll get a message that it couldn't be fixed and it will get temporarily mounted so you can copy files off of it before reformatting. If you're unlucky, the repair will just fail.

    If that doesn't work, you could try doing the same thing with a Windows disk utility, and see if it is able to repair the partition. Or, if the data on it isn't that valuable, just reformat it and try again, although I'd be careful in case it's a hardware problem--it might happen again.

    Almost all USB sticks come formatted as FAT32 or FAT16 (like the one with trouble here). The MacOS can read and write these formats, as can Windows. So unless you've messed with the formatting, almost every USB stick works out of the box on Windows and the MacOS.

    If you've reformatted it as NTFS under windows, or HFS+ on a Mac, then you'll run into the standard issues, but so long as you stick to FAT when reformatting (and a MBR partition scheme), it'll continue to be fine.
     
  10. curtisinoc macrumors 6502

    Joined:
    Mar 13, 2011
    Location:
    Southern California
  11. colintb macrumors newbie

    Joined:
    Jan 14, 2015
    #11
    Go to Finder - Preferences - tick External Disks.:)
     

Share This Page