USB Thumb Drive Won't Do HFS+ Format

Discussion in 'macOS' started by markbyrn, May 14, 2011.

  1. markbyrn macrumors member

    markbyrn

    Joined:
    May 1, 2010
    #1
    I've been trying to format a 128 GB USB thumb drive as a Mac OS Extended volume (HFS+) but it silently fails and the only successful format I can do is MS-DOS FAT. As I want to use the drive to install a dev version of Lion, I need the HFS+ format and trying it in terminal gave the following result:

    Marks-MacBook-Pro:~ markbyrn$ diskutil eraseDisk HFS+ lion disk1
    Started erase on disk1
    Unmounting disk
    Creating the partition map
    Waiting for the disks to reappear
    Formatting disk1s2 as Mac OS Extended with name lion
    Initialized /dev/rdisk1s2 as a 128 GB HFS Plus volume
    Mounting disk
    Could not mount disk1s2 with name (null) after erase
    Finished erase on disk1
    Marks-MacBook-Pro:~ markbyrn$

    So it appears to initialize but won't mount. I also tried partioning the drive into 2 or 4 partitions and formatting an individual partition but that didn't work either.

    I have installed the dev version (preview 2) of Lion on a 16 GB thumb drive but there's not enough free space to do an update to preview 3. Any advice on how I can get this 128 GB thumb drive formatted?
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    "A USB thumb drive" gives no hint as to the manufacturer and model of the drive and which features it may have. My guess is that the drive has a U3 or some other type of protected partition. Unfortunately, these protected partitions can be used only with Windows. They can be modified only with Windows. This being the case, you should use a Windows computer to remove the protected partition. I assume that you will then be able to use Disk Utility on the Mac to format the drive to whichever file system you want.
     
  3. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #3
    "Unfortunately, these protected partitions can be used only with Windows. They can be modified only with Windows."

    Incorrect.

    I believe Sandisk now offers a Mac utility to remove the U3 protection from its drives. That may apply to flashdrives from other manufacturers, but I can't say which ones, because the only experience I've had is with Sandisk.

    That said, the poster is correct that the U3 software is probably usable only with Windows. In some cases, the drive can be re-initialized, but only "partially", as the U3 software resides on some kind of "protected volume". The end result will be that (after Mac initializing) you will see TWO volumes on the desktop, one being the U3 volume and the other being that portion of the flashdrive that OS X was able to "touch" and initialize.

    That was the case with a Sandisk U3 flash drive that I bought. At the time, Sandisk did not have a Mac utility to remove the U3 protection, so I had to take the drive to a PC, mount it, and run the U3 removal application from there.
     
  4. markbyrn thread starter macrumors member

    markbyrn

    Joined:
    May 1, 2010
    #4
    The thumb drive is a Kingston DataTraveler 200 USB flash drive and it does not appear to have U3 protection (ran a U3 removal tool and nothing detected) but perhaps it has some other form of protection that can be removed?

    I loaded the thumb drive on a Windows box and it showed one partition with 128 GB. Oddly enough though, on the Mac, it shows up as "137.44 GB Generic Flash Disk Media" How is that the Mac is reporting an extra 9 GB when and Windows isn't seeing it? As I got this thumb drive from an eBay seller overseas, I'm now wondering if this might be a counterfeit.
     
  5. markbyrn thread starter macrumors member

    markbyrn

    Joined:
    May 1, 2010
    #5
    More info:

    After doing another one partition Mac Journaled format that failed, I selected the unmounted partition and did an erase using MS-DOS FAT and it mounted. Moved the drive over to a Windows box and it said it needed to be formatted and checking the data management function, it showed one 200 MB protected partition and I formatted it - it also showed the 128 GB partition but couldn't format it. Put it back in the Mac and successfully formatted it with HFS+ however it's only 200MB - not quite enough for a Lion install. Tried repartitioning to combine the two partitions and it failed as before. So the best I could do was get a 200 MB partition with HFS+
     
  6. shaivure macrumors newbie

    Joined:
    Sep 9, 2008
    #6
    I'm having exactly the same problems with a cheap 8GB thumb drive I got off eBay. Formats fine as FAT, but I can't get it to format as HFS+ for an OS X 10.6 install (the DVD drive is broken on my Mac Mini and I need to restore).

    It's showing up as '8.39 GB Generic Flash Disk Media' in Disk Utility. I've also tried formatting in Terminal and it just won't mount as HFS+

    Looks like a case of false economy. I suppose I'll just have to buy proper one.
     

Share This Page