Resolved USB - thunderbolt adapter from apple doesn't

Discussion in 'MacBook Air' started by kayleee, Oct 7, 2015.

  1. kayleee macrumors regular

    Nov 20, 2013
    doesn't work on my macbook air 2013 after upgrading to El not sure if I recollect this well, but I think it worked on the 1st day after upgrading but stopped working after that...

    macbook doesn't detect it in network preferences either...someone please help

    used to work perfectly on OSX yousemite...

    Btw I never had problems with this, because its basically PLUG and PLAY and has worked that way since 2.5 years over multiple OS from apple...

    someone please clarify....or maybe my adapter stopped working :/
  2. c8rlo macrumors 6502


    Sep 1, 2015
    is your TB firmware up-to-date? not sure if this is relevant to you, i have an mid-2011 13" MBA and prior to upgrading to El Capitan i had (3) firmware updates involving TB...
  3. kayleee thread starter macrumors regular

    Nov 20, 2013
    Hi what is TB firmware?
  4. cruisin macrumors 6502a


    Apr 1, 2014
    TB ==> thunderbolt

    Go into software update, refresh with ⌘ + R, and see if you have any updates.

    Then go to  > About this Mac > System Report > Thunderbolt

    If your adapter is not showing up there, it might be broken.

Share This Page