Usb to serial no output Yosemite

Discussion in 'MacBook Pro' started by Yogi-HM, Dec 7, 2014.

  1. Yogi-HM, Dec 7, 2014
    Last edited: Dec 7, 2014

    Yogi-HM macrumors newbie

    Joined:
    Dec 7, 2014
    #1
    I recently updated my MacbookPro to Yosemite and have found that my usb to serial cable no longer works. I've tried reinstalled drivers multiple times with no success when I connect my Gigaware usb to serial cable and conect my cisco console cable which used to work fine on Mavericks but now I get no output in my terminal program secureCRT.

    I when my cable is connect I see the following in dev

    hugh-millers-macbook-pro-77:dev Yogi$ ls tty.*
    tty.Bluetooth-Incoming-Port tty.HughsiPhone-WirelessiAP
    tty.Bluetooth-Modem tty.PL2303-00002006

    hugh-millers-macbook-pro-77:dev Yogi$ ls *PL*
    cu.PL2303-00002006 tty.PL2303-00002006
    hugh-millers-macbook-pro-77:dev Yogi$

    Here is what I see in System Information

    USB-Serial Controller:

    Product ID: 0x0fba
    Vendor ID: 0x05ad (Y.C. Cable U.S.A., Inc)
    Version: 3.00
    Speed: Up to 12 Mb/sec
    Manufacturer: Prolific Technology Inc.
    Location ID: 0x04100000 / 4
    Current Available (mA): 500
    Current Required (mA): 100

    SecureCRT is set to use /dev/cu.PL2303-00002006

    Has anyone experienced this issue, can anyone assist?

    Mac Info

    MacBook Pro (15-inch, Late 2008)
    2.53 GHz Intel Core 2 Duo
    4 GB 1067 MHz DDR3
     
  2. snorkelman macrumors 6502a

    snorkelman

    Joined:
    Oct 25, 2010
    #2
    struggling to find any prolific USB serial adapters here (every single one I pull out seems to be FTDI doh!!)

    if I find any tomorrow at work I'll throw Yosemite onto a box and try and have a look for you if no one else manages to come up with anything
     
  3. snorkelman macrumors 6502a

    snorkelman

    Joined:
    Oct 25, 2010
    #3
    drawn a blank on prolific adapters here Could have sworn we had some but everything is FTDI, hopefully someone else can chime in :(
     
  4. Yogi-HM thread starter macrumors newbie

    Joined:
    Dec 7, 2014
    #4
    Thanks, I'm beginning to think it's a hardware issue between my MacBook Pro and Yosemite. I just tried an RS232 serial adapter and I only get 1 line of output as I just connect to the device but then all communication stop. I also notice that Yosemite seems to be loading the drivers for the devices as I didn't install any drivers but noticed one came up as soon as I connected the RS232 usb to serial adapter.
     
  5. Yogi-HM thread starter macrumors newbie

    Joined:
    Dec 7, 2014
    #5
    Ok so I"ve gotten a bit further, after removing the osx-pl2303.kext files and doing a reboot I notice I get output if the usb to serial is connected while the computer is booting. However once I use it and disconnect it will not work when reconnected.
     
  6. Yogi-HM thread starter macrumors newbie

    Joined:
    Dec 7, 2014
    #6

Share This Page