USB too much power message?!

Discussion in 'macOS' started by jenangelcat, Jun 14, 2008.

  1. jenangelcat macrumors newbie

    Joined:
    Dec 15, 2006
    #1
    "The USB device is currently drawing too much power.

    The port it is attached to will be deactivated"

    As of last week, this message pops up when I plug in my digital camera cord. I tried all of the plugs, with and without other things plugged in and this message still pops up. I thought it was the cord but I tried a new camera cord and it's doing the same thing.

    I have an Intel Mac, 2.16ghz, 1GB. It's 2 years old and has never had this problem before.

    I've tried rebooting twice and it's still doing it.

    Anybody have this issue and/or know how to resolve it?
     
  2. mikes63737 macrumors 65816

    Joined:
    Jul 26, 2005
    #2
    Has this camera worked before?

    If you use a powered USB hub it should work fine.
     
  3. jenangelcat thread starter macrumors newbie

    Joined:
    Dec 15, 2006
    #3
    yup been using the camera and cord for 2 years. the message still pops up regardless of whether or not the camera is attached to the cord.
     
  4. jcarlson1030 macrumors newbie

    Joined:
    Jun 16, 2008
    #4
    Help

    I am having the same problem except that port doesn't work. Have you found an answer on how to fix it?
     
  5. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #5
    Do you have another computer you can plug it into so you can isolate the problem to the camera and/or cable or the mac? It's kind of sounding to me like your cable has gone bad, but really can't make that determination without isolating it.
     
  6. jcarlson1030 macrumors newbie

    Joined:
    Jun 16, 2008
    #6
    I do but unfortunately it is not the cables because nothing works in that hub :confused:
    I have used the cables in my other computer. it all started when my 13 yr old used a mouse in the mac. It was working fine for several months and then capute.......it went dead. So i bought an Apple mouse thinking it was the other one and this too did not work in the hub. I hope that helps.
     
  7. arcanemirage macrumors newbie

    Joined:
    Aug 28, 2008
    #7
    My WD 500gb MyBook is doing it too

    When I plug the usb cable into my laptop (2.33ghz Macbook Pro) it gives me the same message. My battery won't hold a charge anymore either. I plugged the same drive into my G4 tower and it gives the same message. Wth is going on?:confused::mad:
     
  8. KMadvisor macrumors newbie

    Joined:
    Apr 19, 2008
    #8
    This is a Mac OS X problem and has nothing to do with the USB device

    Same msg: "The USB device is currently drawing too much power. The port it is attached to will be deactivated" appears as has been reported by those with Camcorders, cameras, etc. My issues is a heasset that worked fine for a year, works on a PC I have, but gets the above message on my Mac.

    The focus of responses (sensibly, i suppose) focuses on the device...but anyone looking as this USB "too much power" issue can see that there is a pattern. However, I find no solution. Can anyone with greater diagnostic skills help?

    KMadvisor
     
  9. ppc750fx macrumors 65816

    Joined:
    Aug 20, 2008
    #9
    It sounds like the device is trying to draw the full 500mA without identifying itself to the host, which is (from what little I recall of the USB spec) in violation of the standard. Does the Mac recognize the device in any way when you get these message? (i.e. does the Mac appear to see the camera? Can you transfer photos, etc?)
     

Share This Page