USB WIFI dongle drivers on 10.6.8

Discussion in 'Mac Basics and Help' started by savedave, Mar 8, 2013.

  1. savedave, Mar 8, 2013
    Last edited: Mar 8, 2013

    savedave macrumors newbie

    Joined:
    Aug 8, 2011
    #1
    Hi there

    I have been having some major headaches with wifi dongles on my macbook pro.

    Background:
    I have a very old MBP. About 18 months ago the airport card more or less gave up. I bought usb wifi dongle about 9 months ago and for a while it worked fine, albeit with an ugly utility. Then about 3 months ago the dongle gave up, or so I thought. The utility acted as though no dongle was connected, and I returned the dongle to the supplier, who refunded me.

    A month ago I bought an ASUS USB-N13, which claims to have mac support. With the software that came with the dongle, the result was the same - the wireless utility said "no device" with the dongle connected.

    Then I tried more recent drivers from the ASUS site and got a marginally improved result - the dongle showed up and did a scan of the signals in the area. But any time I attempted to connect to a network the utility crashed.

    I tried a few third party apps I read about but nothing worked. I tried ASUS support, who were utterly useless - they sent me the windows drivers, sent me to speak to the supplier, and eventually just said they can't do any more than that. (I'd advise against ASUS for mac users based on this experience).

    Today I tried to uninstall and reinstall the driver and utility but on both reinstalls I got this error:

    "System extension cannot be used. The system extension "/System/Library/Extensions/RT2870USBWirelessDriver.kext" was installed improperly and cannot be used. Please try reinstalling it, or contact the product's vendor for an update."

    This is beyond my level of technical competency - I don't know anything about kext, and the supplier and manufacturer say they cannot help.

    Although the installer completed and said the installation was complete, currently nothing happens when I plug in the dongle and it does not even light up on its LED.

    I don't know what to do but I desperately need a wireless connection. Can anyone advise?

    thanks so much.
     

    Attached Files:

  2. savedave thread starter macrumors newbie

    Joined:
    Aug 8, 2011
    #2
    more kext errors

    I tried it again and now I get two additional errors - images posted
     

    Attached Files:

  3. Getekid macrumors newbie

    Joined:
    Apr 6, 2013
    #3
    Hello

    Had the same problem with a ZyDAS USB wlan adapter. Every time I tried to install the drivers those two errors were coming up about the .kext files. Funny thing is that my Mac could see the adapter when connecting it anyway (you can check it in System Profiler under USB).

    Finally made it work by installing "Wi-Fire". Download the software from here (download link near the end of the page), install, reboot, then plug in your dongle. It will automatically trace it and start working. For more info about the wi-fire you can check the site or the manual that is included with the setup.

    Hope that works for you :)!!
     
  4. Getekid macrumors newbie

    Joined:
    Apr 6, 2013
    #4
    hfield domail expired

    Hello everybody !!

    I 'm making another post because apparently, the hfield link I made above broke because their domain expired...

    I need to download the installer (Wi-FireInstaller2) again, is there anyone who has downloaded it that can send it to me?

    Thanks a lot in advance :) !!
     
  5. PhotoDropBox, Jul 12, 2014
    Last edited: Jul 13, 2014

    PhotoDropBox macrumors newbie

    Joined:
    Jul 12, 2014
    Location:
    Vernon BC Canada
    #5
    For Mac OS 10.6.8 for the ASUS USB-N13 Hackintosh see: https://www.youtube.com/watch?v=Ke7mljlkTqQ
    http://www.macbreaker.com/2013/08/the-best-usb-wifi-adapters-for-your.html

    Driver install tips says
    "If you got install failed message, please re-install again until success.
    Because it is a bug on Snow Leopard.
    There is no install setting for OS 10.6 on install tool, so we use OS 10.5 to instead of it temporarily.
    We will update it on Apple as soon as possible."

    Do I downloaded the software, ran it and sure enough 1st crack installation failed.
    2nd attempt, bingo. looks good. My local Mac Store Simply.ca stocks it. Driving down there this minute to buy it and try it.

    QuestionL
    It says I must go into Preferences => Network to configure it.
    Old guy here. Tried. Nada. No instructions... what do I do to configure it?

    Ddd dumb ass question.... Do I need to uninstall Airport?

    ASUS USB-N13
    http://www.asus.com/Networking/USBN13/

    Google key words search terms:
    Mac OS 10.6.8 Wifi connection problems / failure / drop out.
     
  6. PhotoDropBox, Jul 13, 2014
    Last edited: Jul 13, 2014

    PhotoDropBox macrumors newbie

    Joined:
    Jul 12, 2014
    Location:
    Vernon BC Canada
    #6
    Sigh. No go. May need to pay to get my Mac Tech guy to come in...

    There is a honey of a PC manual. Nada for Mac.

    Does not show up as a device.
    Nothing in Network Preferences.
    ______________

    Sigh. My hopes were so high. Massive Wifi dropout issues here. Lucky to have one minute of internet connection.
    Then my IP address will get taken over by another device on the D-Link router here.
    ===> Nightmare to reconnect. <===

    Zap the Pram repeatedly, pull the power plug for a minute, replug in for 10 seconds before restarting (forget what that process is called on the Mac) ... Shut down the Router for a full minute, clean all the connections on the router and modem...
    - that makes a bit of a difference. 5 minutes connection which steadily decreases until nada, booted out again...

    Such high hopes for reliable wifi. No hard line ethernet option here.
     
  7. adubadom macrumors newbie

    adubadom

    Joined:
    Mar 2, 2012
    Location:
    Philippines
    #7
    USB WIFI dongle drivers on 10.6.8

    Hello! Below is the link for the driver. It is universal. Hope it helps.

    http://store.bearextender.com/pages/bearextender-1200-support
     

Share This Page