USB Wireless Mouse - clicking works, moving doesn't

Discussion in 'Mac Basics and Help' started by in/flux, Jan 31, 2008.

  1. in/flux macrumors newbie

    Joined:
    Jan 23, 2008
    #1
    I have a Logitech cordless mouse with the base station attached to my MacBook Pro through USB. I can sometimes right-click, but I cannot use the mouse (move it around, etc.) I have tried re-connecting, unplugging and plugging in the USB, resetting the device, and power cycling the device, and none of this works.

    It works for a while usually, and then after a few minutes just doesn't work anymore. What's wrong?
     
  2. marykay9507 macrumors 6502a

    marykay9507

    Joined:
    Jan 18, 2008
    #2
    have you tried logitech's website to troubleshoot-- could be the mouse that is the issue?
     
  3. Firm macrumors newbie

    Firm

    Joined:
    Sep 16, 2008
    Location:
    Belgium
    #3
    Same here

    I've got the same problem but with the mighty mouse from apple :(

    Every function works (clicking, scrolling, side buttons) except moving the pointer around...

    This is going on for some time now but never found a forum where they've got the same prob...

    Any suggestions?
     
  4. Nanookfan macrumors member

    Joined:
    Apr 13, 2008
    #4
    Hi, I had a similar issue with a Logitech wireless mouse, where mine would move normally but the scroll wheel would not work. I thought the scroll wheel may have died, but tried things such as updating and reinstalling the software ect. None of these worked. The next thing I tried, just for grins, was booting up into Safe Mode. My mouse has been working normally ever since. Sometimes you have to love the simple things when they work. Anyway, if you haven't already, you might try this. Power on your Mac and hold the Shift key down from the time you hear the 'bong' until you see the whirling circle. Starting up in Safe Mode will take longer than normal and you will most likely hear your fan running fast for a while.
     

Share This Page