Use Time Machine to restore iphone app?

Discussion in 'Mac Basics and Help' started by Boca, Oct 30, 2009.

  1. Boca macrumors 6502

    Joined:
    Feb 13, 2008
    #1
    Hi, Istat was a great app that allowed iphone users to clear memory for better performance. That was vs 1. Apple made them remove this function. I made the mistake of upgrading to the latest version of istat and it removed the MC function.

    How can I get the VS 1 of the istat app back on my iphone? Can I go into my external time machine back up and pull a single app out and re install it?

    If so can someone please walk me through how to do this?

    many thanks,
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Should be relatively straightforward.

    First, open a Finder window, if one isn't already open.
    Second, navigate to ~/Music/iTunes/Mobile Apps (where ~ means your home folder).
    Third, restore the older version. This can be done in one of three ways:
    1. Invoke Time Machine, and find the older version from its interface.
    2. Browse your TM drive manually to find the file that needs restoring, then drag & drop it to where it needs to go.
    3. Use both approaches - i.e. by manual browsing, find which dated backup contains the file you want, then do the actual restore via the Time Machine interface.
    Finally, sync your device as normal.
     
  3. UngratefulNinja macrumors 68000

    UngratefulNinja

    Joined:
    May 9, 2009
    Location:
    Pennsylvania
    #3
    Check your trash folder, if you haven't already. When itunes updates an app, it deletes the previous version.
     
  4. Boca thread starter macrumors 6502

    Joined:
    Feb 13, 2008
    #4
    Hi WW ,
    Thanks for the info. I get the istat from TM, move it to itunes but get an error message saying it can not be moved error -50) Any advice appreciated.
    Thanks to all you who try and help us helpless ones out. :) Have a great weekend.

    UN, thanks for suggestion. Checked it and it's got the 1.1 version...the no good version as far as I'm concerned. Still having problem following WW advice but will keep at it until I get this resolved. thanks again.
     

Share This Page