Useless Apple Care; Home Kit sticks on "Loading Accessories and Scenes"

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by dan9700, Feb 24, 2018.

  1. dan9700 macrumors 68030

    dan9700

    Joined:
    May 28, 2015
    #1
    I have never gotten Home Kit to work. The first time I tried was about six months ago, after buying an iDevices WiFi outlet. The very first time I tried launching Home Kit, the system stuck on "Loading Accessories and Scenes" interminably. After reading that others would eventually get a message that they needed to reset Home, I tried leaving it for days. No matter what I tried, same result. I've tried the following:



    • Erase phone and restore from backup
    • Erase phone and set up as new phone
    • Use a different phone
    • Use a different iPad


    Using a different Apple ID works, but there's no way I'm switching Apple IDs with the years of emails and app purchases I have attached to this one.


    So I called Apple Support, since the phone has Apple Care. I've called Apple Support for two significant issues over time, and both escalated to the top-tier support people. And in both cases the result was the same.



    • Support escalation to senior advisor
    • Install stuff to collect logs, etc.
    • "We're waiting for the analysis of the logs"
    • Service advisor starts missing our follow-up appointments
    • Service advisor stops responding to my emails
    • I give up in frustration


    It really feels like this is written into their procedures somewhere. "If the tech team is unable to determine the source of the issue, or determines the source but is unable to provide resolution, cease responding to the customer, who will normally give up out of frustration."



    Clearly, there is some Home Kit data stored in iCloud, and clearly mine is irrevocably broken. The idea that Apple simply can't resolve that--can't clear out Home Kit data for someone whose Home Kit HAS NEVER WORKED, simply amazes me.
     
  2. dan9700 thread starter macrumors 68030

    dan9700

    Joined:
    May 28, 2015
  3. u49aa2 macrumors 6502a

    u49aa2

    Joined:
    Nov 3, 2008
    Location:
    Between Heaven and Hell
    #3
    i would try:

    1- open home kit and delete all accessories.
    2- open the applications (hue, LIFX) and unpair the accessories
    3- Hard reset the accessories
    4- re-install the Homekit app and start repairing


    This helped me when one of the Homekit sensors stopped working

    cheers
    aa
     
  4. TrueBlou, Mar 13, 2018
    Last edited: Mar 13, 2018

    TrueBlou macrumors 68040

    TrueBlou

    Joined:
    Sep 16, 2014
    Location:
    Scotland
    #4
    Being the most obvious causes of this issue I’m sure you’ll have covered it already, but just in case, do you have Two factor verification and iCloud Keychain enabled on the Apple ID? Both are required for HomeKit to work.


    Oh, and one other almighty pain in the ass thing that some people have had success with resolving the issue, assuming you already have both of the above enabled. Is resetting the iCloud Keychain. If you decide to go down this route make sure you’ve a backup of all of your passwords/login information and so on before you do. Better yet, do a complete backup of your keychain as well so you can restore it if needs be.

    Personally I’d rather not do that and instead see if the Apple engineers could reset your HomeKit data from their end.
     

Share This Page

3 February 24, 2018