useless iPhoto 'sharing'

Discussion in 'iPad' started by -BigMac-, Apr 16, 2012.

  1. -BigMac- macrumors 6502a


    Apr 15, 2011
    hi guys,
    i bought the iphoto app for my ipad 3.
    after adding effects to a photo from camera roll, i 'share the edited photo' back into camera roll. The photo is ALWAYS highly pixelated, almost as if the photo processing didnt complete.

    this doesnt change no matter how long i wait looking at the photo in camera roll.
    Because of this, iPhoto is completely useless for me.

    Anyone else experienced this pixelation?
  2. waynep macrumors 6502

    Dec 31, 2009
    I did not recall that problem, so I just tied it on my iPad. I did not get a pixelated photo. It looked fine. Not sure what direction to suggest though . .
  3. jeffkempster macrumors member

    Oct 31, 2008
    I have used the new iPhoto and no pixelation for me either. At the very least I would erase iPhoto from the iPad. Then reboot the iPad by holding down the top and home buttons for 10 seconds until the white apple logo appears. Then I would redownload iPhoto and try again.

    If you post some screen shots it may help us.
  4. NTeggerdine macrumors member

    Jul 3, 2011
    Montrose Iowa
    After I did not experience this problem I tried several different way to make it happen so then maybe I could see what was going on with your pics. I could not make this happen for the life of me. I would maybe try reinstalling the app and if it continues contact apple support.
  5. -BigMac-, Apr 16, 2012
    Last edited by a moderator: Apr 16, 2012

    -BigMac- thread starter macrumors 6502a


    Apr 15, 2011
  6. iHeartsteve macrumors 65816


    Feb 12, 2012
    I use iPhoto and that's never happened to mine. You're right it seems like it can't fully finishing applying the effect to the photo. Is this a photo you took using iPad or another high res photo that you then downloaded on iPad? When did you download the iPhoto app and did it download from your saved backup from iTunes?
  7. BFizzzle macrumors 68020


    May 31, 2010
    Austin TX
    i love your username

    sorry no problems here for me! on my ipad and iphone 4s
  8. -BigMac- thread starter macrumors 6502a


    Apr 15, 2011
    just reinstalled, rebooted. same thing.

    the photo was downloaded from an external site. with preset ipad 3 resolution.

    I downloaded the app pretty much on launch day, and just now re downloaded it, and same thing.

    This is clearly not sufficient enough, as i paid for this app.
  9. PrayForDeath macrumors 6502

    Jan 3, 2012
    Did you try other pictures? Like something taken with your ipads camera?
  10. GraphicsGeek macrumors 6502a

    Sep 19, 2008
    I've had this problem with images saved from the web. But not using iPhoto. Sometimes they'll appear like that in the Photos app.
  11. iHeartsteve macrumors 65816


    Feb 12, 2012
    Hmm not sure but it just seems like iPhoto couldn't handle processing the photo. Is it high res photo from website? Depending what effect you tried applying makes a difference. iPhoto on an iPad is very simplistic version and no where near the capabilities of photoshop so thats my guess. And obviously iPad power doesn't compare to a desktop.
  12. -BigMac- thread starter macrumors 6502a


    Apr 15, 2011
    ipad taken photos arent effected by this problem. only ones which have been downloaded from an external source. This is more annoying, as a majority of my wallpapers are from an external site.

    Apple did not market this app for 'iPad-only photo editing'.
  13. iHeartsteve macrumors 65816


    Feb 12, 2012
    This, try another photo applying the same effect
  14. -BigMac- thread starter macrumors 6502a


    Apr 15, 2011
    same pixelation on external pics
  15. iHeartsteve macrumors 65816


    Feb 12, 2012
    Yes apple didn't market iPhoto for iPad only photos. However it seems like your using some extremely high res photos. I guess apple just assumes that iPhoto is for quick on the go applications. For the amateur. Sorry I think you may just have to use photoshop. Or if you really want to use this effect. Convert this image to smaller Jpeg first.
  16. rocknblogger macrumors 68020


    Apr 2, 2011
    New Jersey
    I was able to recreate this issue by trying to edit a wallpaper I downloaded. This is not good. That's a pretty glaring limitation.
  17. -BigMac- thread starter macrumors 6502a


    Apr 15, 2011
    didnt realise 2000x2000 is an 'extremely high res'


    PERFECT!!!! glad im not the only one... was thinking theres something wrong with my ipad. what now?
  18. brand macrumors 601


    Oct 3, 2006
    Wait for an update.
  19. AceCoolie macrumors regular

    Jun 19, 2009
    I've had it happen when creating a journal and sharing it.
  20. BrennerM macrumors regular

    Jun 17, 2010
    Kitchener, Ontario, Canada
    Wonder if this is because you are getting interlaced GIFs/PNGs from the internet. Looks like interlacing artifacts to me. Probably an iPhoto bug. I've used it on 13MP images from my camera and never saw this issue.
  21. dmccloud macrumors 6502a


    Sep 7, 2009
    Anchorage, AK
    They said at the iPad announcement that iPhoto for iOS would handle images up to 19MP in size. If the images in question are higher than that it could be causing issues. I use iPhoto on my iPad with images shot on a Canon Rebel T2i (18MP) and haven't had any issues like that at all.
  22. spiderman0616 macrumors 68030


    Aug 1, 2010
    Also make sure that the image you downloaded was not the thumbnail of the image, but the actual image itself. I've fallen into that trap before.
  23. Mak47 macrumors 6502a

    Mar 27, 2011
    Harrisburg, PA
    I've never seen it after sharing to the camera roll. Sometimes after I've edited a bunch of photos, if I go back to view them in iPhoto they appear distorted--but the shared file is perfect. This is anything from iPad photos, to pictures beamed from the iPhone 4S, to photos imported from various digital cameras. It's an irritating bug, but not one that has a lasting effect.

    Yours sounds different.
  24. MythicFrost macrumors 68040


    Mar 11, 2009
    Have you checked that the pixelation isn't already there on the original? I've read that Safari automatically downscales images of a certain size or greater, so even though you may be visiting a site with 2048x1536 resolution images, they may be getting downscaled to even 1024x768.

    I seem to remember it being okay when saved directly to iPhoto, but I'm not sure about that.
  25. b.c., Apr 18, 2012
    Last edited: Apr 18, 2012

    b.c. macrumors 6502

    Nov 5, 2008
    I'm using iPhoto on iPad and don't see this problem when editing photos I've uploaded to the iPad from my DSLR (via camera connection kit). Images I edit retain their full resolution *

    I'm wondering exactly how you are downloading the photos from Internet to your camera roll, and if they are being downsized at that step (not by iPhoto later when editing)?

    Here's something to try: after downloading the image but before editing, check the image resolution in the camera roll before touching it. Some 3rd party apps will let you open camera roll images and show you the image resolution, for example the free app called PhotoPad

    Be sure the source image you're editing is exactly what resolution you think it is before you edit

    *update: I rechecked and in iPhoto I notice edited photos that are saved back to the camera roll seem to be downsized. however if you look at same edited photo within iPhoto, in the "Edited" album, those edited photos are still full resolution. so something is going on with resizing back to the camera roll?

Share This Page