User icon pictures are unavailable -are priests involved?

Discussion in 'OS X Mountain Lion (10.8)' started by virtualruffy, Feb 25, 2013.

  1. virtualruffy macrumors newbie

    Feb 25, 2013
    Figured the headline would get attention.
    Anyway, I've seen several posts about this, some without responses, but no solutions.
    This is an upgraded from 10.7 to 10.8 macbook pro as part of an image build.

    No user shows any of the default or custom user icons available in the users system preference. All the Apple icons are present in the /Library/User Icons folder as well as custom but they do not appear within the system's panel period. No icons appear there. You are able to add icons to it -per user. Any done in this manner are saved in that user's preferences so this does not affect the system level. I have tried removing preferences. I have tried removing the icons and adding them back including as root but all changes are applied to the user only. I have run Diskwarrior, repaired permissions, etc. And nothing changes this so it has to be a corrupt Library preference of some sort that is affecting all users. The question is What Preference?

    If anyone knows or can figure it out please let me know. I don't want to scrap an entire image and rebuild it if I can avoid it. And now that it has annoyed me I want to solve it. As it has happened to numerous people it is not a once-only occurring problem. Rare perhaps but not unique.
    thanks for any ideas.
  2. virtualruffy thread starter macrumors newbie

    Feb 25, 2013
    update -problems continue

    I cloned the image to another laptop, deleted all preferences from main library, restarted, logged in. Still no user pictures shown for default user. In case the original users were corrupt, I created a new user and logged in with it. It was given one of the OSX pictures randomly chosen by the system. I logged in as user and still no pictures are shown. Tried to do a reinstall of 10.8.2 combo update and system refuses saying i cannot be done. Booted from recovery partition and it will allow an internet recovery. Yay. Estimating 1.5 hrs. And this is on a fast network. Outgoing Bandwidth for this throttled by Apple I'm sure.

    All this is suggesting something in the system files themselves is corrupt and that's not good -and it may be a result of something in the 10.8.2 updater as it occurred after doing that update. If 10.8.3 releases soon I'll be interested to see if that fixes it or has no effect.
  3. virtualruffy thread starter macrumors newbie

    Feb 25, 2013

    Log errors: System Preferences[5082]: --ImageKit Error: Error loading user pictures from /Library/User Pictures/.DS_Store
    System Preferences[5082]: --ImageKit Error: Error loading user pictures from /Library/User Pictures/Animals
    are examples I searched on and found these two articles:

    but none of the solutions were effective for me. So I logged in as root and trashed the old user icon images file then copied the folder from a ML factory disk image. This worked. So if anyone else encounters this issue there are several methods to try in increasing severity to resolve it.

Share This Page