User login password regularly being refused

Discussion in 'OS X El Capitan (10.11)' started by e4xit, Sep 28, 2015.

  1. e4xit macrumors newbie

    Joined:
    Dec 24, 2012
    #1
    OK so I am having quite a strange issue here, basically one of the user login passwords for the machine seems to be getting changed or corrupted every few days (1-3 days) after the computer is powered off.

    This is requiring me as admin user to log in and reset the password to via the Users & Accounts preference pane.

    When this is done, the user can then log in but it says that their Keychain password is required. Sometimes this works with a previously used login password but sometimes not with any password, requiring the whole keychain to be deleted and rebuilt, which is all quite annoying as you can imagine.

    I have tried to eliminate as many possible potential user-error causes which might lead to this behaviour, such as changing keyboards, ensuring CAPS lock is on/off etc., but even using a simple password such as "password" we may come back tomorrow and find that it no longer is accepted by the OS?

    Anyone have any ideas on how to troubleshoot? I guess I might be able to solve in one way by creating a new user account and trying to migrate documents over to it but ideally would like to avoid that.

    Thanks.
     
  2. mikecwest macrumors 6502a

    mikecwest

    Joined:
    Jul 7, 2013
    #2
    Are YOU the user that keeps having to login issue, or is it another user? Maybe, if it is another user, they have it set to use their iCloud password. If they then change the iCloud password on their phone, the password will change with the user account.
     
  3. e4xit thread starter macrumors newbie

    Joined:
    Dec 24, 2012
    #3
    Hi mikecwest, thanks for your reply.

    I am the primary user (and admin) of the computer. I created a second (admin) user acc. for my SO to use for photoshop etc. It was all working OK until one day, with the same password that had worked for months, her pw suddenly stopped working. This is when as I said we tried different keyboards and other common potential issues. Forced to reset the password via logging in to my account.

    One time after this happened I went into keychain to investigate and was prompted to delete the keychain and start again. Bit the bullet and assumed that this was a necessary evil which was required to fix/reset everything but it still has happened again since then.

    Have just found this KB https://support.apple.com/en-gb/HT201609 so will perhaps double check that login and keychain are at least on the same password, but I don't think that will help with OS X suddenly not accepting user's login password... :S
     

Share This Page