User lost permissions on home folder

Discussion in 'Mac Basics and Help' started by DennisBlah, Oct 30, 2018.

  1. DennisBlah macrumors 6502

    DennisBlah

    Joined:
    Dec 5, 2013
    Location:
    The Netherlands
    #1
    Hi all,

    I can't really find a similar post. One of my clients has a macBook Pro 2016, which has been encrypted on High Sierra and updated recently to Mojave.

    The problems started off with searching within his email.
    As common as it is, I ran the outlook search tool from microsoft and it solved it at that moment.

    The next day he called me again and running it again did not work. So I disabled and removed his spotlight and started the indexing again.
    sudo mdutil -i off /
    sudo rm -rf /.Spotlight*/
    sudo mdutil -i on /
    sudo mdutil –E

    This solved the issue again, but today he called me up again that it's gone again!

    After trying to remove his spotlight settings in ~/Library/Preferences I figured he had no access to his folder...
    Going a bit more up I found he had no access to his Desktop (in a Finder window, but from the desktop itself it worked fine..)
    Further up his homefolder received the username and group from the local admin account...

    After fixing this with sudo chown -R username:staff /Users/username it's fixed and searching worked straight away.

    Now I'd like to know if others are facing the same issue as I'm afraid this is going to re-ocure again, and this client is our Branch Director :D
     
  2. hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #2
    Used to be a nice home directory reset built into Recover Mode. Sadly, it has been removed.

    Now this is the way....


    More info here. This Dev has a lot of interesting tools...including Repair Home Permissions in his download area (about 2/3 of the way down). Seems to be a GUI for the command above. Used it a couple times, worked great.
     
  3. DennisBlah thread starter macrumors 6502

    DennisBlah

    Joined:
    Dec 5, 2013
    Location:
    The Netherlands
    #3
    Hi hobowankenobi,

    My issue was that the ownership of his homefolder changed to the one from the local administrator account.
    It's a miracle he could login at all!

    His issue's started when I encrypted his drive, updated his osx to mojave and migrated his email to an O365 license.

    I could not find anything similar on the internet on this issue, so it might just been a one-time thing... I hope...
     
  4. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #4
    The most likely explanation is that you make a mistake. I know you don't think you did, but if you noticed yourself making it then you would have not done it.

    Let's hope I am right because if I am this is not likely to ever happen again. It was a one-off accident, so kind of typo.
     

Share This Page

3 October 30, 2018