UserEventAgent ( not responding)

Discussion in 'macOS' started by surferfromuk, Oct 29, 2007.

  1. surferfromuk macrumors 65816

    Joined:
    Feb 1, 2007
    #1
    This is in red in my process list - anyone know the cause ?
     
  2. rhoydotp macrumors 6502

    rhoydotp

    Joined:
    Sep 28, 2006
    #2
    i've been trying to get any information about this. i tried to "force quit" the process and it re-spawns. after it re-spawns it seems to be working.

    anybody else having this issue?
     
  3. rhoydotp macrumors 6502

    rhoydotp

    Joined:
    Sep 28, 2006
  4. applewiz macrumors newbie

    Joined:
    Nov 1, 2007
    #4
    well, i'm here... have no clue what this is but i have the same UserEventAgent Not Responding in my Activity Monitor. Someone please help us figure this out, thanks.
     
  5. rhoydotp macrumors 6502

    rhoydotp

    Joined:
    Sep 28, 2006
    #5
    hahaha! it's good to know that you are there :D

    anyhow, i seem to have found what the issue is on my machine. my drivers for my tascam US122L. Looking thru my /var/log/system.log file, i saw some references to coreaudiod crashing. and this happens whenever i have the device connected. i tried to re-create the problem by removing the driver and re-installing it. as soon as i plugin the device, boom! same issue. now that i removed the driver completely, the UserEventAgent stays up.

    the issue is now, i cannot use my device any longer :(

    here's what i see on the logs

    Code:
    Nov  1 19:36:39 mackoy /usr/sbin/spindump[134]: process 117 is being monitored
    Nov  1 19:36:46 mackoy kernel[0]: ...2 HUB(s) in path detected (including root hub)
    Nov  1 19:36:46 mackoy kernel[0]: start PGKernelDeviceTascamUSB2 v1.2.4.0 success
    Nov  1 19:36:47 mackoy kernel[0]: USBF: 49.359  AppleUSBEHCI[0x3b7b000]::UIMCreateBulkEndpoint: USB 2.0 Spec (5.8.3) converting MPS from 9 to 512
    Nov  1 19:36:47 mackoy kernel[0]: terminate PGKernelDeviceTascamUSB2 v1.2.4.0
    Nov  1 19:36:47 mackoy kernel[0]: ...2 HUB(s) in path detected (including root hub)
    Nov  1 19:36:47 mackoy kernel[0]: start PGKernelDeviceTascamUSB2 v1.2.4.0 success
    Nov  1 19:36:47 mackoy kernel[0]: USBF: 50.139  AppleUSBEHCI[0x3b7b000]::UIMCreateBulkEndpoint: USB 2.0 Spec (5.8.3) converting MPS from 9 to 512
    Nov  1 19:36:50 mackoy ReportCrash[136]: Formulating crash report for process coreaudiod[105]
    Nov  1 19:36:50 mackoy com.apple.launchd[1] (com.apple.audio.coreaudiod[105]): Exited abnormally: Segmentation fault
    Nov  1 19:36:51 mackoy ReportCrash[136]: Saved crashreport to /Library/Logs/CrashReporter/coreaudiod_2007-11-01-193646_mackoy.crash using uid: 0 gid: 0, euid: 0 egid: 0
    Nov  1 19:37:00 mackoy kernel[0]: terminate PGKernelDeviceTascamUSB2 v1.2.4.0
    
    
     
  6. applewiz macrumors newbie

    Joined:
    Nov 1, 2007
    #6
    hey, me again... i was just coming back to tell you that i found that my digidesign core audio plug in (located in Library>Audio>Plug ins>HAL) was causing the problem. Deleted the plug in and n more 'not responding'... hmmm, obviously a similar issues. This is a lame question but how/where did you get the log in? Thanks!
     
  7. rhoydotp macrumors 6502

    rhoydotp

    Joined:
    Sep 28, 2006
    #7
    coreaudio bug or driver issues

    really interesting. i wonder if it is only the 3 of us that is having this issue right now :confused:

    i got the log via "terminal", file is /var/log/system.log
     
  8. johantheolive macrumors newbie

    Joined:
    Nov 1, 2005
    #8
    Make that four of you with a not responding usereventagent:rolleyes:
     
  9. dombookpro macrumors member

    Joined:
    Oct 18, 2007
    #9
    Me too! Installed Leopard two days ago, and have had this problem since. On both my G5 and my MacBook Pro. I'm also having a problem with my G5 indexing the spotlight but that's a whole other story! Would be happy if someone figured out what this problem is. Will attempt to look in logs
     
  10. xzu macrumors newbie

    Joined:
    Nov 2, 2007
    #10
    hello guys, I'm new here... because... now we are 6 !

    I got usereventagent in red
    I also got coreaudio in red (well that is why I'm posting here due to previous messages)

    I sample UserEventAgent in activity monitor :
    Then same for coreaudio pid

    1°) do you have the same issue on your sides ?
    2°) what is
    ?

    For the record :
    I'm PPC G5 dual 2Ghz
    3 G ram
    FCPro studio 2 user (used upgrade from previous studio)
    Logic Pro Suite 1 (upgrade from Logic Pro 7)
    Leopard retail DVD install using "install and archive old system"
    + Evolution Midi Keyboard

    I hope we can fix this, and I'm sure it involves around audio driver, I'm ready to go into code stuff and terminal investigation, but alone, I don't know where to start.
    thx for the help
     
  11. xzu macrumors newbie

    Joined:
    Nov 2, 2007
    #11
    Bad news,
    I know exactly when the Tasks crashes and hangs... I have a Firewire Host Card that allow me to plug in USB and FW 400 drives

    As soon as I plug in / switch on the drives, the tasks CoreAudio and EventUserAgent Crashes into Activity monitor.

    I did not make the test when Drive is plugged onto built-in Firewire of The G5 (same bug for many friends, only on dual 2, 2.2, 2.7 ... Ghz PPC

    Whith the help of a friend, I'm pretty sure it has something to do with the Dual PPC Extensions, because now I see what is "AVComponents"...

    it is relative to VC.plugin IO service and IOFireWireAVC.kext the one that handles input and output to firewire.

    Once I shut down drives and firewire access, all goes back to normal.

    I don't get a thing to code, and kext in kernel, but if someone understands what is happening here, please help on reporting to Apple. Thx
     
  12. sawaca macrumors newbie

    Joined:
    Nov 5, 2007
    #12
    Same

    I have the same usereventagent (not responding) after installing Leopard
     
  13. surferfromuk thread starter macrumors 65816

    Joined:
    Feb 1, 2007
    #13
    Yep, that fixed it for me too. Great work wiz!

    Looks like Digidesign need to get busy fixing my Pro Tools for Leopard.
     
  14. bunkre macrumors member

    Joined:
    Mar 10, 2004
    #14
    me too

    Ive been getting this too, not I'm 90% sure its Digidesign Core Audio. I don't want to kill it yet though, cause its always such a pain in the ass to get Pro Tools up and running (update this, install that, no *this* core audio app now.. ugh)

    I swear, every issue I've had upgrading OS's since 9.2 has been because of Digidesign. I'm sure they'll charge me for an upgrade now to make this work.
     
  15. buzzz macrumors newbie

    Joined:
    Jan 16, 2008
    #15
    usereventagent not responding - a fix for me

    I opened the folder UserEventPlugins which can be found in System > Library > UserEventPlugins and moved all the plugins to another folder. You must then delete the plugins from the UserEventPlugins folder which requires authorization. I restarted and opened the Activity Monitor. UserEventAgent was working fine. I then added each plugin one at a time back to the UserEventPlugins folder with a restart in between (which incidentally takes forever since installing Leopard). I kept adding, restarting then checking Activity Monitor until UserEventAgent stopped responding. I finally found the culprit. It was BluetoothUserAgent-Plugin. Since I removed it UserEventAgent is working fine - so far. :)

    As it happens I'm not using any Bluetooth items. Hope this helps.

    Also for some odd reason all the plugins in the UserEventPlugins folder show up as Adobe Photoshop plug-in files - go figure.
     
  16. BVGuitarPlayer macrumors regular

    Joined:
    Jan 14, 2006
    #16
    For anyone else interested:

    I have confirmed the above post fixed this on my MBP C2D running 10.5.0, later upgraded to 10.5.1 where the problem persisted.

    "BluetoothUserAgent-Plugin.plugin" was the culprit for me.
    Also notable however, on other threads, people have blamed DigiDesign & ProTools which I have installed (DigiCoreAudio as well).

    While I do have ProTools installed on my system the BluetoothUserAgent was the problem for me. I removed the file, save it in case you need it later. I really don't know what it does. I have an iPhone, so I don't use BT that much these days. Probably related to listening for other BT devices?
     
  17. coocooforcocoap macrumors regular

    coocooforcocoap

    Joined:
    Sep 22, 2007
    Location:
    kathmandu, nepal
    #17
    Add another to the list, removed the HAL dir and problem was removed...not sure what that does to ProTools however...
     
  18. soundsgoodtome macrumors regular

    soundsgoodtome

    Joined:
    Jun 8, 2007
    Location:
    Los Angeles
    #18
    Worked for me, too. Thanks....

    By the way -- are you guys aware that officially, Pro Tools is definitely *not* Leopard-compatible, yet? Digidesign has made that very clear, so I was actually surprised to see that so many guys, here, who use PT had upgraded to Leopard.

    My main Digital Performer/PT machine is still running Tiger, for that very reason. But due to other incompatibility issues (with certain 3rd-party Virtual Instruments), I'm not able to upgrade to PT 7.4 on the Tiger machine.

    So I recently installed PT 7.4 on my MacBook Pro (which was already running Leopard), just to play with elastic audio. A friend who works closely with Digidesign told me "it might work, since you won't be running a complex setup on your MBP." So I installed it -- but started getting random freezes, as well as the UserEventPlugins issue in Activity Monitor. Googling "UserEventPlugins" brought me to this thread, so thanks to you who identified the culprit.

    Bottom line: Be very cautious if attempting to run PT on Leopard Machines. Who knows what other havoc is taking place under the hood.
     
  19. bgiancola macrumors newbie

    Joined:
    Jul 14, 2007
    Location:
    Saratoga, CA
    #19
    UserEventAgent not responding

    Removing the BluetoothUserAgent-Plugin also worked for me. Thanks buzzz! :D
     
  20. CmdrTulkas macrumors newbie

    Joined:
    Jul 14, 2008
    #20
    What negative side effects would removing the "HAL" folder or "BluetoothUserAgentPlugin.plugin" file?

    I use bluetooth on my Macbook Pro for several things, mostly importantly syncing with my phone.
     
  21. HaveBlue83 macrumors newbie

    Joined:
    Aug 2, 2007
    Location:
    West Grove, PA~ Stationed at Fort Polk, LA
    #21
    Yup......

    I just trashed the BluetoothUserAgent-Plugin and my red UserEventAgent problem is GONE!!! WOO HOO!!!


    that has been bothering me for a LONG time.

    I have 10.5.4 with current Firmware. I have been having some other issues with performance, but this has also been going off like clockwork. It's now black text and operating normally. FINALLY I found this thread :)

    thanks guys!

    i knew 10.5 would be quirky.....lol....
     
  22. drjuice macrumors member

    Joined:
    Aug 19, 2008
    #22
    I have

    In samples of UserEventAgent and coreaudiod. What do I do now?
     
  23. jawknee macrumors newbie

    Joined:
    Nov 5, 2008
    Location:
    California
    #23
    More info on UserEventAgent and Lockups

    I was seeing lockups - seemingly random - but every time I sent mail, most times when starting up Mail, always when leaving it open for a while. I'd see it every time ran iTunes, once with image grabber, etc.

    Found the problem. My sounds are going out through Core Audio to my Mbox 2. This has worked for some time - until I moved my Belkin USB hub to another Mac and put a new Kensington DomeHub in its place. The DomeHub alone is sufficient to put up the UserEventAgent (not Responding) message - but not enough to cause the lockup problem until the Mbox was hooked up. It was the various apps trying to make sound that caused the lockup.

    Moving the Mbox2 to a main USB port on the Mac G5 solved the problem and allows me to use the Mbox2 for sounds and mixing.

    Hope this helps.
    -jk
     
  24. allan.nyholm macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Denmark
    #24
    The iTunes plugin called Hear also makes UserEventAgent to be not responding just so you know, just in case you want to install that.
     

Share This Page