UserEventAgent using 114% cpu

Newfiejudd

macrumors regular
Original poster
Jul 8, 2010
141
0
I noticed the UserEventService hogging serious amount of CPU usage. Just wondering if someone could aid in helping me diagnose what service is causing the high CPU usage, as UserEventAgent pertains to multiple applications.

Thanks in Advance.
 

addiecool

macrumors newbie
Mar 9, 2002
15
0
New Delhi, India
Here is a fix

I have a 2013 Retina 15.4" Macbook Pro and 2012 Retina MBP. Was having the same issue with UserEventAgent hogging up 117-140% CPU.

The following worked for me to temporarily solve the issue. I nneded to get it solved as my battery lasted only 1.5 hrs due to high CPU use.

Go to

System/Library/LaunchAgents

and "move" the following files out of the folder to any place safe.

1. com.apple.UserEventAgent-LoginWindow.plist
2. com.apple.UserEventAgent-Aqua.plist

OSX will ask you for admin authentiction.

Once done. Reboot and the HIGH CPU usage should be gone.

I noticed that these are agents used to trigger important system drivers (as far as I know and I may be stupid) but so far it has not affected anything at all. System is running fine for the last 2 hrs.

Just my two cents.

If this screws up things for anyone, pretend you never read this. ;-)
 

freezer2000

macrumors newbie
Jun 12, 2013
5
0
I have a 2013 Retina 15.4" Macbook Pro and 2012 Retina MBP. Was having the same issue with UserEventAgent hogging up 117-140% CPU.

The following worked for me to temporarily solve the issue. I nneded to get it solved as my battery lasted only 1.5 hrs due to high CPU use.

Go to

System/Library/LaunchAgents

and "move" the following files out of the folder to any place safe.

1. com.apple.UserEventAgent-LoginWindow.plist
2. com.apple.UserEventAgent-Aqua.plist

OSX will ask you for admin authentiction.

Once done. Reboot and the HIGH CPU usage should be gone.

I noticed that these are agents used to trigger important system drivers (as far as I know and I may be stupid) but so far it has not affected anything at all. System is running fine for the last 2 hrs.

Just my two cents.

If this screws up things for anyone, pretend you never read this. ;-)
I tried the same process and now not able to boot my MBP, its getting stuck with booting and the Apple logo turns into a circle with slanting line across it...
Please help
 

richard.mac

macrumors 603
Feb 2, 2007
6,292
2
51.50024, -0.12662
I had this problem with my Haswell MacBook Air after a fresh install of Yosemite dev build. UserEventAgent was always loading a core straight after boot.

For me the culprit was UserEvent plugin 'com.apple.cts.plugin'. After renaming it to disable it and rebooting, my mac is now idling.

Here are the commands I used

Code:
cd /System/Library/UserEventPlugins
sudo mv com.apple.cts.plugin com.apple.cts.plugin.disabled
 
Last edited:

richard.mac

macrumors 603
Feb 2, 2007
6,292
2
51.50024, -0.12662
I have a 2013 Retina 15.4" Macbook Pro and 2012 Retina MBP. Was having the same issue with UserEventAgent hogging up 117-140% CPU.

The following worked for me to temporarily solve the issue. I nneded to get it solved as my battery lasted only 1.5 hrs due to high CPU use.

Go to

System/Library/LaunchAgents

and "move" the following files out of the folder to any place safe.

1. com.apple.UserEventAgent-LoginWindow.plist
2. com.apple.UserEventAgent-Aqua.plist

OSX will ask you for admin authentiction.

Once done. Reboot and the HIGH CPU usage should be gone.

I noticed that these are agents used to trigger important system drivers (as far as I know and I may be stupid) but so far it has not affected anything at all. System is running fine for the last 2 hrs.

Just my two cents.

If this screws up things for anyone, pretend you never read this. ;-)
I tried the same process and now not able to boot my MBP, its getting stuck with booting and the Apple logo turns into a circle with slanting line across it...
Please help
I wouldn't recommend deleting/moving a launch agent/daemon without knowing the repercussions. Especially if it has a core UI element in the name, as after reboot you could not load your desktop!

Renaming a plugin to disable it would be a much safer option and it shouldn't cause boot issues. You can then rename it to activate it if needed.

freezer2000 if you have another bootable OS X install, you could move the plist files back to the original location into /System/Library/LaunchAgents on your Yosemite disk

Or you could try boot into Single User Mode (command+S on boot up) and mount the disk with mount -uw / and move the plist files back to /System/Library/LaunchAgents with mv and then reboot.
Google 'Single User Mode' and 'terminal mv' for more info.

If you do not have these plist files anymore, then reinstall Yosemite.
 

nitant

macrumors member
Oct 16, 2007
41
55
Maple land
Had the same issue on my 2013 MacBook Air. Moving com.apple.cts.plugin from /System/Library/UserEventPlugins, solved the issue for me. Now it seems to be back to Mavericks levels.

Thanks a ton for that @richard.mac

Any clue what it does though?
 

richard.mac

macrumors 603
Feb 2, 2007
6,292
2
51.50024, -0.12662
Not sure what it does though, but it is a plugin loaded by UserEventAgent, which loads plugins that cannot be loaded by launchd (which is a service manager).
 

freezer2000

macrumors newbie
Jun 12, 2013
5
0
Back to Yosemite again...

Ok... consider it as a false alarm of the steps mentioned here causing the boot issues. After hours of investigation and support from forum members, it my Trim Enabler app running on non Apple SSHD drive causing the issue. It went bad to the point that I could not even login to the recovery and did not have my old Macbook to try anything.

After spending the whole weekend sorting it out, I am back on Yosemite with no data loss. After installation the temps still were as high as 80-85C so followed the steps to take care of the high CPU by Usereventagents and after reboot, everything is cooled down to Mavericks level of 45-50C at idling.

Thanks for all your support.
 

haravikk

macrumors 65816
May 1, 2005
1,494
21
Just a note to people having this issue; remember to grab a profile of the offending process via Activity Monitor, or run sysdiagnose (hold shift - ctrl - alt - command - period, a Finder will open eventually with a .zip file in it) so you can attach one of these to a bug report at bugreport.apple.com

Obviously bypassing the offending process helps you to keep testing the rest of the preview, but it's no good if the issue isn't fixed before it reaches general release ;)
 

sachin234000

macrumors newbie
Apr 20, 2012
19
0
India
Very frustrating issue. MacBook runs hot with battery drain

I have same problem on my MBPr 15". UserEventAgent is consuming not less than 116% CPU. Scared to move/delete system files as it may affect OS.
This bug should be reported to apple ASAP.
I have default apple ssd and it's not the problem of ssd as other member may have figured.

----------

Ok... consider it as a false alarm of the steps mentioned here causing the boot issues. After hours of investigation and support from forum members, it my Trim Enabler app running on non Apple SSHD drive causing the issue. It went bad to the point that I could not even login to the recovery and did not have my old Macbook to try anything.

After spending the whole weekend sorting it out, I am back on Yosemite with no data loss. After installation the temps still were as high as 80-85C so followed the steps to take care of the high CPU by Usereventagents and after reboot, everything is cooled down to Mavericks level of 45-50C at idling.

Thanks for all your support.
I have default/factory ssd on my MBPr 15 and this issue is affecting my machine too.
 

jmazzamj

macrumors regular
Jun 11, 2009
199
0
I noticed the UserEventService hogging serious amount of CPU usage. Just wondering if someone could aid in helping me diagnose what service is causing the high CPU usage, as UserEventAgent pertains to multiple applications.

Thanks in Advance.
I was experiencing the same issue while copying big files from the downloads folder to the application folder. Fan was spinning like crazy...
Yes, it was obviously an app, specifically the Yosemite installer app itself.
The Air quickly cooled down and cpu usage went back to normal right after the copy ended.

Very weird if you ask me...
 

dominzak

macrumors newbie
Jul 26, 2014
2
0
I had this problem with my Haswell MacBook Air after a fresh install of Yosemite dev build. UserEventAgent was always loading a core straight after boot.

For me the culprit was UserEvent plugin 'com.apple.cts.plugin'. After renaming it to disable it and rebooting, my mac is now idling.

Here are the commands I used

Code:
cd /System/Library/UserEventPlugins
sudo mv com.apple.cts.plugin com.apple.cts.plugin.disabled
I can confirm that the above solution fixed abnormal CPU usage issue on my 13" 2014 MBA. I just moved that file to my Documents folder instead of renaming it, but result is the same - usual CPU usage (same as in 10.9).
Thanks a lot for giving me this fix. I've reported that issue using Feedback Assistant so hopefully Apple will fix it in the next update.
 

CaliValleyBro

macrumors newbie
Jan 29, 2018
1
0
***edit, hope it worked.

New to this so I am learning the ropes and didn’t mean to “reply” the entire post that was written.

I signed up after reading some of other posts and specifically the replies and knowledge, you, “Richard.mac” had regarding directories and not only utilizing the terminal but how to accomplish removing files, etc via terminal especially when there are issues with logging in to an account.

What I am hoping for, is when I “post” my issue I would like to have the opportunity to have your input (Richard.mac)

Problem is, I am not sure how to post just yet or how to ensure you would be able and available to see it and help.

(Forgive my comment that is not related to this particular topic or forum? If that’s the correct terminology)
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.