usernoted process keeps crashing

Discussion in 'OS X Mountain Lion (10.8)' started by Boiling Ice, Sep 9, 2012.

  1. Boiling Ice macrumors newbie

    Joined:
    Sep 19, 2011
    #1
    I've notice that "ReportCrash" is running all the time on Activity Monitor. Reading System.log it turns out that usernoted keeps relaunching and crashing. I've rebooted in recovery mode, fixed permissions and repair disk but still nothing fixed. what is that process actually?

    I've tried to find out what causes the issue, any idea on how to help?

    I have also noticed that clearing Notifications from Notification Center takes about 5 to 7 seconds to clear; which indicate something is wrong but I can't figure out what's causing the crash.

    I have a MBP 15" Early 2011 with Mountain Lion 10.8.1
     
  2. RonArt macrumors member

    RonArt

    Joined:
    Jan 22, 2010
    Location:
    Southern California
    #2
    Same problem with usernoted

    I'm having the same problem with usernoted.

    I looked at Console and there are lots of crash reports.

    And when I look at Activity Monitor 'usernoted' keeps appearing there approx. every 10 seconds for approx. 1 second and then disappears (crashes).

    What made me look for this problem is that I was having a problem with simply dragging a file from one folder to another. The folder in the background didn't want to come to the foreground as it would usually do. And no matter how many times I let go of the file after knowing it should have moved... it didn't.

    I don't recall this happening in 10.8.1.

    I'd suggest filing a bug report with Apple but don't bother. Seriously.

    Apple only allows developers to file bug reports and Radar is so frustrating and non-responsive that it's usually not even used.

    And as far as filing Feedback... yeah right.

    If you go to Apple's feedback page they don't even allow you to file bugs regarding Mountain Lion. Don't take my word for it... go look.

    So until the next update (i.e. 10.8.3) is released... we're probably stuck with this.
     
  3. nyolc8 macrumors regular

    Joined:
    Jul 20, 2012
    #3
    usernoted is notification center related... it means user notification daemon or something... if you check the files that it uses (you can check that in activity monitor), you'll see notification center.
     
  4. RonArt macrumors member

    RonArt

    Joined:
    Jan 22, 2010
    Location:
    Southern California
    #4
    Bark was the problem

    Boiling Ice... the plugin "Bark" was the problem.

    After using "Find Any File" to root out every file that Bark had installed (since Bark's UNinstaller did not work for me)... I rebooted and 'usernoted' remained active without crashing.

    Hopefully this will solve your problem as well.

    And if you don't have Bark installed... you may want to delete Hiss or any other plugins for Growl... at least as a test.
     
  5. Mactabulous macrumors member

    Joined:
    Dec 23, 2011
    #5
    usernoted

    I'm having usernoted going crazy on me too, since 10.8.2. CPU use peaks at 99.9%, wherein my MBP fans obviously go into hyper overdrive; temperatures soaring at 90°C.

    Killing the usernoted process relieves the CPU… but only for so long!
     
  6. Soundguyrob macrumors newbie

    Soundguyrob

    Joined:
    Oct 3, 2010
    Location:
    Indy
    #6
    Did anyone find a fix to this? I booted into safe mode to troubleshoot something. When I rebooted this report pops up and returns as soon as you dismiss?
     
  7. texasswift macrumors newbie

    Joined:
    Sep 4, 2012
    #7
    YES! Just yesterday, I booted into Safe Mode for another reason. Now I am seeing this same problem. Near as I can tell, it started as soon as I did the SafeBoot. I have repaired permissions ad nauseam, even grabbed a new 'usernoted' binary from the 10.8.3 Combo update using Pacifist. No help.

    Leaving the original binary in place, I get a segmentation fault, SIGSEGV. Using the new binary (which 'diff -b' says is identical), I get an illegal instruction signal, SIGILL.

    I'm stuck. A clean install is my next thought, but i REALLY don't want to do that just to fix some odd Notification Center problem.
     
  8. docwhat macrumors newbie

    Joined:
    Sep 3, 2012
    #8
    Trashing Bark fixed it.

    I'd suggest quitting growl and seeing if that fixes it. If it does, then start looking for plugins.

    Removing Bark fixed it for me as well.

    If you have growl from the App Store (most likely nowadays) then you need to remove the Bark.growlView directory from:

    ~/Library/Containers/com.Growl.GrowlHelperApp/Data/Library/Application Support/Growl/Plugins

    Triple click the above line, right-click (or control click), and select Services->Reveal

    Then drag the folder to the trash and restart growl. The uninstaller is broken.
     

Share This Page