Using a Non-MobileMe Alias With Mobile Me

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Makanmata, Jun 21, 2009.

  1. Makanmata macrumors member

    Joined:
    Jun 21, 2009
    #1
    I am a former blackberry user, and enjoying almost everything about my new Iphone 3GS, but having terrible trouble with only one specific issue. I am trying to accomplish two things on my Iphone simultaneously: 1) receive Push email; and 2) make my replies to emails appear to come from my firm's domain ("firm.com").

    I signed up for MobileMe, and had all of my emails forwarded to my me.com account. This has worked well to solve the push issue, and now the emails appear on my Iphone instantly. Good so far.

    My problem is meeting the second goal of making replies appear to come from my firm.com address. On my Blackberry, this was easy, and although my replies were routed to and from my "blackberry.net" account, the appeared to come from firm.com, just as if they had been sent from my desk. MobileMe however, seems unable to do this, and aliases are limited to other me.com names. This is unacceptable to me.

    I have asked both the Apple Store staff, as well as MobileMe Support, if I can solve this problem, and neither have been able to. Before I am forced to return the phone however, I thought I would let the real experts at this issue, and see if this problem can be solved.

    Is there any way I can receive push email (it doesn't have to be Mobile Me, but I do not have access to MS Exchange Server) and be able to make my replies appear to come from my firm.com email address.

    Many thanks in advance.
     
  2. DavidFL macrumors member

    Joined:
    Mar 25, 2008
    #2
    Try this...

    Here is how I did it.

    First, it sounds like you have the inbound messaging pretty well figured out.

    Try creating a NEW, additional mail account for your "firm.com" email that includes the "firm.com" pop3/imap server and smtp server info. It is as though you are setting up firm.com as a mail account (which, evidently, cannot push).


    Since you are forwarding all of your mail in this account to your me.com account, you should never get anything in your Inbox in this account.

    Whenever you create a new outbound message, or reply to a message where you want the "firm.com" return address, do this:

    When you begin creating the message, fill in the "To" field (if necessary), the next line is the "Cc/Bcc, From" line. It will show your me.com address as the From. Tap on this line and it will now give you separate fields for CC:, BCC:, and From:.

    Tap the "From" line (which will still be showing your me.com address). It will now bring up a picker which will allow you to select your "firm.com" address. Pick it.

    Your message will now be from your "firm.com" address, and sent through your firm.com SMTP server.

    It is kind of a pain to have to do this for every message, assuming that you want ALL of your messages to show from me.com, but it does work. I've just gotten used to it so I don't think about it any more.

    Any questions let me know.
     
  3. lefse macrumors member

    Joined:
    Jul 11, 2008
  4. Makanmata thread starter macrumors member

    Joined:
    Jun 21, 2009
    #4
    DavidFL, many thanks for the very good advice, which was far more helpful than any of the advice that I received from Apple and MobileMe, who were quite adamant (the MobileMe person in particular) that MobileMe could not support a non me.com alias. You have proven this to be incorrect information.

    As you recognize though, while this advances the ball solidly in the right direction, this is still a bit of a pain. Could there be a more seemless solution? I wonder if there is a way to make the firm.com come up as the default address, rather than have to fix it every time?

    Thanks again for the very good advice.
     
  5. srl7741 macrumors 68020

    srl7741

    Joined:
    Jan 19, 2008
    Location:
    In my world
    #5
    Go to Settings/Mail, Contacts, Calendars. Scroll down to Default Account and select the account you would like to be the default which is the account you reply from or compose from.

    I think?
     
  6. Makanmata thread starter macrumors member

    Joined:
    Jun 21, 2009
    #6
    I'm afraid that's not it, as firm.com is already set as the Default. Thanks though.
     
  7. DavidFL macrumors member

    Joined:
    Mar 25, 2008
    #7
    If you are starting a new email, as opposed to doing a Forward or Reply, there is a way. As you enter mail, go into the firm.com inbox, rather than the mobile me inbox (there won't be anything there, but who cares?).

    Hit the icon for new message, and the firm.com address will be the "from".

    If you are replying/forwarding, you will be in the mobile me account since that is where your inbound message is. That is why, I think, it defaults to your mobile me as the from.

    I have tried modifying the server information in the Mail settings menu...doesn't help.

    I have tried deleting the Mobile Me account from the iPhone and then forcing it to sync from my Mac, and that doesn't help either (even though the Mail app on the Mac lets me set up the Mobile Me account with a different outbound address).

    It seems that the Mobile Me settings on the iPhone just don't allow for it. The options for inbound/outbound server information are not as complete as they are on the Mac.

    Anyway, if you manage to find a way, let me know!!

    David
     
  8. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #8
    There is a way to do what you want: It's a bit messy to set up but once you're up and running it's pretty smooth.

    What you need
    A MobileMe Account
    Your Corporate Account
    A GMail Account (probably easiest to set a new one up just for this)

    What you do
    1) In your GMail account, add an additional "send mail as" address which is your corporate e-mail address (under settings / accounts). Confirm that you own this address by clicking on the link that will be sent and then go back into settings and make this account the default. Set the "Always reply from default address" radio button

    2) On the iPhone, go into Mail settings, then Account Info for your MobileMe account

    3) Go into SMTP

    4) Go to Add Server and enter the following details:
    Host Name: smtp.gmail.com
    User Name: Your Gmail account setup earlier
    Password: Password for the Gmail account

    Once you've added this, go into the primary server (smtp.me.com) and turn it OFF. Go into the GMail server you've just added and turn it ON


    That should be all you need to do. Now, when you send an email from your mobileme account it will actually go through GMail's SMTP Server (and will appear in the sent items on that account as well as your MobileMe account) where it will be altered to have the From address that you specified when setting up your GMail account.

    how does it work?
    GMail has a very useful feature that allows you to send as an alternative e-mail address (as long as you can confirm you can collect mail to that address). You can also set it up to always send mail as if it's from that address whenever you use the account. What these changes do is set Gmail up so it does that and then use the Gmail SMTP server for sending mail instead of the MobileMe one.
    When GMail sees the incoming mail your login associates it with your account, and the settings to always send as the alternative address kick in with the result that the mail is sent to the recipient with a sender of your corporate e-mail address.




    This gives you push MobileMe email with an alternative sender address :)
     
  9. OlgaJ macrumors 6502

    Joined:
    Mar 27, 2009
    Location:
    Florida
    #9
    Phil, Great input! I was trying to use me.com for push notification of my gmail premium account (my domain) and didn't realize that I can change the SMTP server. It makes so much sense that it escaped my radar. :)

    The only problem with using a free gmail account with "corp" address that I see is that the header of a reply will show both the gmail account name and the "corp" account name.

    OTOH, if the "corp" email system has authenticating smtp server, then one can use their own corp SMTP info in connection with the me account.

    Thanks much for sharing that!
     
  10. Makanmata thread starter macrumors member

    Joined:
    Jun 21, 2009
    #10
    Thanks Phil.

    But I am under the impression that emails sent in that fashion will say something like "sent on behalf of XXXX@gmail.com (or somesuch). Is that right? If so, while that isn't the worst thing in the world, I would really like to avoid the recipient seeing any other address in the headers other than the XXXX@firm.com email address.

    Thanks again.
     
  11. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #11
    When I tested it, the from header was the correct e-mail address (i.e. the override one) and it showed up as such in Mac OS X Mail. I have seen instances like you mention in the past, but I can't remember the circumstances...
     
  12. Makanmata thread starter macrumors member

    Joined:
    Jun 21, 2009
    #12
    Thanks Phil. I'll give that a try.
     
  13. OlgaJ macrumors 6502

    Joined:
    Mar 27, 2009
    Location:
    Florida
    #13
    What you see depends on the recipient's email program.

    Does your corporate email support authentication for using their SMTP server? If so, you can enter your corporate SMTP info in the iPhone and it will then show your corporate email addy.
     
  14. spangled macrumors newbie

    Joined:
    Jun 22, 2009
    Location:
    England
    #14
    In desktop Mail.app I found the way to get around that annoying "sent on behalf of XXXX@gmail.com" thing was to set up my Gmail account to send via a different SMTP server (ie not Gmail's servers). If you use a different SMTP server, then that doesn' t happen.

    [FYI, I use an authenticated SMTP service (www.authsmtp.com - I have no involvement with them, only recommending them) because I'm often on different WiFi networks. Costs about £25UKP a year, depending on volume of messages.]

    I'd be interested to know if this is possible in Mail.app for iPhone. I'm considering purchasing an iPhone shortly, but the whole issue of being able to send email so that it looks like it's coming from different email addresses (which all route to my primary Gmail account) is key.

    I don't have a MobileMe account and don't really want to have to set one up in order for multiple-email-identity functionality to work on an iPhone.
     
  15. Makanmata thread starter macrumors member

    Joined:
    Jun 21, 2009
    #15
    Olga, I am told that the corporate email will support SMTP authentication. Can you explain for me what I need to do to take advantage of this? Many thanks.
     
  16. OlgaJ macrumors 6502

    Joined:
    Mar 27, 2009
    Location:
    Florida
    #16
    On the iphone, go to System settings > mail, contacts, calendars

    Then tap on your me account > account info > SMTP

    Turn smtp.me.com OFF.

    Under Other SMTP Servers > Add Server

    Host name will be: SMTP.YOURCORPNAME.com (same as you have in your regular email settings on your desktop)

    User Name: enter your name@corp.com email address.

    Password: enter the password you use for your regular mail.

    Now, instead of using me.com to send out your email, you are using your regular email server and it should show your corporate email address.
     
  17. Makanmata thread starter macrumors member

    Joined:
    Jun 21, 2009
    #17
    Olga, I have now turned off SMTP for MobileMe, and instead pointed outgoing mail to my corporate SMTP Server. The mail is being sent fine, but unfortunately, this has not solved the problem that the replies are still defaulting to being from mobileme.com, and not the corporate email address (although I can still tap it and bring it down the pull down menu).

    It seems that we are tantalizingly close, but for this last step of making it default to the corporate address instead of the MobileMe address.
     
  18. DavidFL macrumors member

    Joined:
    Mar 25, 2008
    #18
    Phil,

    Your method works perfectly for me!! Thank you!

    I do not seem to be getting any "sent on behalf of gmail" stuff, either. Just looks like it came from my non-mobile me address.

    Isn't it amazing what we can accomplish when we collaborate!?!?!?

    Makanmata - on the iPhone, it still thinks thate the me.com address is the "from". However, gmail smtp server is changing that and the real life message goes out correctly. No need to change it as you send. I think you need to use the Gmail server, and not your corporate server, unless your corporate server offers the option to change the from address. My "corporate" address is with netaddress, and even if I change my mobile me account on iphone to use the netaddress SMTP server, it still shows outbound messages as being from me.com. You need an SMTP server that allows this "masking option" that Phil describes. GMail is probably the easiest (and certainly cheapest) one to find.

    Also...it seems that Gmail is putting a copy of these messages into the Gmail inbox. I fixed that by adding a filter that any messages coming from my "corporate" address should skip the inbox and be deleted.

    Now everything is perfect, unless, of course, any of the me.com, corporate.com, or gmail.com servers go down, in which case I will be burned toast!!
     
  19. Makanmata thread starter macrumors member

    Joined:
    Jun 21, 2009
    #19
    Im disappointed to tell you that this isn't working for me, and emails sent from my Iphone show up in my Outlook as XXXXX@gmail.com on behalf of XXXXX@Firm.com.

    Apparently, not all email programs show from who an email was "sent" and that might be why it appears to be working on certain programs. Unfortunately, Outlook does generally show this info, and the "on behalf of stuff" appears for those that use it (which is a lot of people).

    Google seems to have purposely designed it this way, with spam filters in mind: http://mail.google.com/support/bin/answer.py?hl=en&ctx=mail&answer=22370

    Am I missing something, or is it back to the drawing board?
     
  20. DavidFL macrumors member

    Joined:
    Mar 25, 2008
    #20
    You're right!!

    I normally use Mac Mail but after your report about Outlook I fired up an old PC and used Outlook....and it does show the "on behalf of" thing.

    And here I thought it was solved.........

    Sorry for the misinformation. From where I sat it looked like we had a winner.
     
  21. Makanmata thread starter macrumors member

    Joined:
    Jun 21, 2009
    #21
    Are there any other services that operate like gmail, but don't include the "on behalf of" stuff? That's the only missing piece in this puzzle.
     
  22. OlgaJ macrumors 6502

    Joined:
    Mar 27, 2009
    Location:
    Florida
    #22
    Sorry for the delay in responding. I've been trying different things.

    When I use my me account with my gmail account smtp, as I've mentioned before, it works perfectly. (That's because I have my own domain name parked at google for email, and have a premium account, so I don't end up with that double email with "on behalf of.")

    *If* I add a Yahoo account to my email accounts, without touching the me account, things change! The ME account loses the gmail server, and in email I am given the option of the me account smtp server or that of the Yahoo account. Gmail SMTP is not even an option! In the meantime the SMTP settings for the ME account have not been changed and still show the Gmail SMTP server name. So it's not following the SMTP settings that are there.

    *If* I render that Yahoo account inactive, then all is well again.

    How many accounts do you have on your iPhone? Turn all but the ME account OFF. You don't have to delete them, just make them inactive. Then try to use your ME account with your corporate SMTP and see if it works.

    I think that while some of these things are by design, there are others that cannot be. There is no reason that the behavior of the ME mail app, as I have it configured and as it works, should change just because I add a Yahoo email account to my iPhone.
     
  23. Makanmata thread starter macrumors member

    Joined:
    Jun 21, 2009
    #23
    Thanks Olga. As far as I can tell this is all by design, and meant to be in compliance with various web standards. I don't think its that Google is adding this information, but rather that it is merely included as part of a standard email "header" and certain email readers (like Outlook, but not Thunderbird) are designed to read that header and give us the dreaded "on behalf of."

    Having done some research, I see that MS Exchange has a way to suppress this information from being included in the header, http://technicians-blog.kingcompute...essage-as-another-exchange-2003-outlook-user/ and Google has taken note of the mass unhappiness that "on behalf of" has wrought and is working on a method to suppress it on gmail, but it is not promised to come anytime soon. http://groups.google.com/group/Gmai...863?lnk=gst&q="on+behalf+of"#3a8bcd0548487863 As you point out, GoogleApps can apparently do this, if you have the flexibility to allow them to host your entire mail domain, but I'm not sure that is a step I am prepared (or able) to make for the privilege of keeping the Iphone.

    Apple is obviously in the best position to fix this simply and easily by supporting non me.com aliases either within MobileMe or the Iphone -- as Blackberry has done with its devices and blackberry.net since it was first released many years ago. The Iphone has the potential to make work a bit less dreary, but there seems to be a real price to pay in terms of email performance. The blackberry is orders of magnitude less fun to use, but as far as email is concerned, blackberry just works -- without the significant time investment I have had to put into making the Iphone work the way I would like, and unsucessfully at that. Its really frustrating that something so simple doesn't seem to have a simple solution.

    Thanks again for all of the help, which is greatly appreciated.
     
  24. Makanmata thread starter macrumors member

    Joined:
    Jun 21, 2009
    #24
    Does anybody happen to know if the MobileMe update released yesterday might provide a solution to this issue?
     
  25. OlgaJ macrumors 6502

    Joined:
    Mar 27, 2009
    Location:
    Florida
    #25

Share This Page