Using Airport express in bridge mode

Discussion in 'Mac Accessories' started by Ofvitinn, Jun 5, 2009.

  1. Ofvitinn macrumors newbie

    Joined:
    Jun 5, 2009
    #1
    Hi.
    I am having a problem with my airport configurations.

    My setup:

    I have a router from my ISP with one cable out which goes into a hub. From there, I have connected my ipPhone, my media center, and my Airport express.

    Now the media center's IP number is aaa.bbb.ccc.ddd.
    The IpPhone is aaa.bbb.ccc.eee.
    So the airport express should be aaa.bbb.... at least.... right (My airport is set up to be in bridge mode)?
    but in fact, the Airport has the IP number fff.ggg.hhh.iii.

    How can this be? I am using DHCP, so should'nt my ISP just give me one IP number, and my hub distributes the last one or two sets of digits?
    I want my Airport to be a sort of an extension of my hub, only for wireless devices.


    As you can see I am pretty new to networking, and must admit that I dont fully understand all this, but I thought I had it all under control.... :)

    Is there anyone out there who has experienced a similar problem, or anyone who can help me in solving this?
     
  2. kmcgrody macrumors newbie

    Joined:
    May 7, 2009
    Location:
    Fairport, NY
    #2
    Express set up

    sounds like a confusing set up. When you say router from ISP with cable do mean the actual cable modem? If you have cable you should have a cable modem that your outside cable hooks into. Then you have a connection to your wireless router or "hub". And I assumne that when you say ipPhone it is some type of Voice over IP like Skype? If that is the case I do not know much about VOIP but I have heard that is can screw up computer internet connections. Also you do not need to hard wire your Airport express to your other router. Finally is your media center a Windows/PC?

    I would try;
    1. If you are cable ISP, call your cable company. They may need to reset on their end with the new Mac Express. I had to have them reset and then things worked.
    2 Get the VOIP out of your set up just to see if it is screwing things up. If it is I don't really now how to help you to make it all work nice together.
    3. Try Airport express not physically connected to your router, use as wireless. Just plug it in to any outlet in a room. The Airport express utility should set it up when it finds it. If it can't find it see number 3 below
    3. If your media center is a Windos/PC make sure all the Firewalls are off and/or allowing your Airport express to get through. This includes windows firewalls and any antivirus software firewalls.

    Usually when you have a different IP address' there's usually a firewall issue or your cable ISP needs to reset.

    Good luck
     
  3. Ofvitinn thread starter macrumors newbie

    Joined:
    Jun 5, 2009
    #3
    Airport and bridge

    Hi, sorry for my unclear explanation.

    I have a broadband connection.
    have a cable going from my phonejack to my brodband-modem (provided by my ISP) and it is conected to a 4 outlet router (or hub?)by a LAN cable. So far, nothing is wireless.
    My media-center (XBMC) is connected to the router by with a LAN cable as well, and so is my ipPhone (proabably not the cause of any of this. I have been using it for ages and there have been no problems (it is a simens gigaset ip phone))
    I might ad, that everything has been working like a charm until a couple of weeks ago.
    My Airport express is connected in the same way as the media center and the phone.
    I use the Airport to connect to the internet and ftp onto my media center with my iMac or a number of laptops I use in my home.

    Now in order to ftp into my media center, I have to set my airport to run in bridge mode, right? If I dont, I wont be able to connect to my media center (the IP numbers of my laptop/iMac wont start with the same numbers as my media center), i think...?

    And this is my problem. I have no trouble getting online via my Airport express. There are no problems, except for ftp into my media center.
    When I first set up my Airport express in bridge mode, everything worked fine. The airport used to publish ip number who started with the same numbers as the media center had. But now it publishes a new set of IP numbers.

    And the only thing that has changed since is that I have set up little snitch, but I dont see how that can affect my Airport....

    So for sugestion nr. 2,3 and 4 (presuming that the second 3 was a typo :) ), I kinda rule them out.
    As for sugestion nr. 1, do you think that it will change everything (I will call them on monday and have them reset my connection)?

    thanks for your reply...

    p.s.
    I have also tried to disable little snitch, but that did not help.
     
  4. pjarvi macrumors 65816

    pjarvi

    Joined:
    Jan 11, 2006
    Location:
    Round Lake, IL
    #4
    Sorry i'm not more familiar with this, but there should be an option for the Airport Express to not provide DHCP service itself and instead use the DHCP service of the router.

    UPDATE - Found the following instructions:
     

Share This Page