Using an ID3Tag Framework

Discussion in 'Mac Programming' started by bliblablo, Nov 9, 2008.

  1. bliblablo macrumors newbie

    Joined:
    Oct 20, 2008
    #1
    Hey guys,

    i just got an ID3 Framework to read out MP3 tags. The problem i have is, when i add the framework in xcode it wouldn't compile anymore.
    Is there anything spezial i have to do? I downloaded the framework from here:
    http://drewfamily.homemail.com.au/Cocoa_-_ID3Tag_framework.html
    I unzipped it and put the ID3.framework folder to System->Library->Frameworks
    In Xcode i added it by clicking the Frameworksfolder and choose "Add-> Existing Frameworks..." I chose the ID3.framework folder and it was there (And seemed to be ok)
    As soon as it's there i get a compiler error:

    Code:
    Building target “AufgabenListe” of project “AufgabenListe” with configuration “Debug” — (1 error)
        cd /Users/ - myname - /Documents/Xcode/AufgabenListe
        /Developer/usr/bin/gcc-4.0 -arch i386 -isysroot /Developer/SDKs/MacOSX10.5.sdk -L/Users/ - myname - /Documents/Xcode/AufgabenListe/build/Debug -F/Users/ - myname - /Documents/Xcode/AufgabenListe/build/Debug -filelist /Users/ - myname - /Documents/Xcode/AufgabenListe/build/AufgabenListe.build/Debug/AufgabenListe.build/Objects-normal/i386/AufgabenListe.LinkFileList -mmacosx-version-min=10.5 -framework Cocoa -framework ID3 -o /Users/ - myname - /Documents/Xcode/AufgabenListe/build/Debug/AufgabenListe.app/Contents/MacOS/AufgabenListe
    ld: framework not found ID3
    collect2: ld returned 1 exit status
    But the ID3.framework folder is there for sure... Do i need to register this framework somehow somewhere?
    I tried to contact the author of the framework but his email is not working any more.
    Would be great if somebody could help me (i'm new to mac and xcode ;) )

    Greetings, BliBlaBlo
     
  2. Sayer macrumors 6502a

    Sayer

    Joined:
    Jan 4, 2002
    Location:
    Austin, TX
    #2
    You have to copy the framework into the Bundle of the app using a new build phase called "Copy files."

    THen it will work.
     
  3. bliblablo thread starter macrumors newbie

    Joined:
    Oct 20, 2008
    #3
    Sorry, i'm not sure if i understood you correctly.
    I should copy the ID3.framework folder into the directory where i have my app?
    I'm new to macs and to XCode, so i'm not that familliar :) (and my english isn't perfekt ass well :) )
    Would be great if you could give me a "dummy" explanation ;)

    Greetings, BliBlaBlo
     
  4. bliblablo thread starter macrumors newbie

    Joined:
    Oct 20, 2008
    #4
    Ok, i managed to do that... no more compile Error.
    I did it by right clicking "Target" and then ->Add->New Build Phase->New Copy Files Build Phase
    As the path i draged in the "ID3.framework" and it filled in the path "/System/Library/Frameworks/ID3.framework"

    Now compiling works...

    But i still can't call:

    #import <ID3/MP3Header.h>

    What do i have to do to manage this?

    Thx for helping :)
     
  5. bliblablo thread starter macrumors newbie

    Joined:
    Oct 20, 2008
  6. bliblablo thread starter macrumors newbie

    Joined:
    Oct 20, 2008
    #6
    So really nobody????
    I guess for a pro this is no problem at all.... So i can't believe nobody can help me...

    Greetings...
     
  7. wojciechgabrys macrumors newbie

    Joined:
    Nov 14, 2008
    #7
    I'm not a pro, but here it goes :p

    Grab your ID3.framework, and drag it into your XCode window, directly to Frameworks > Linked Frameworks (in your project sidebar, as shown below):
    [​IMG]

    In the sheet, that rolls down after releasing your mouse, be sure to check Copy items to destination group's folder (if needed)
    [​IMG]

    The last thing to do is to include ID3.framework header file:

    PHP:
    #import "ID3/TagAPI.h"
    Final notes:
    The ID3.framework is already in your project directory, so there's no need to create Copy Files Build Phase. Your compiled application folder structure should more or less like this:
    [​IMG]


    Drop me a line at: (skypeID: pixelique) or (ICQ: 85055819) and tell me how it worked. I'm developing an app based on ID3.framework right now, so we could help each other during development ;)

    good luck, take care!
    pixel
     
  8. bliblablo thread starter macrumors newbie

    Joined:
    Oct 20, 2008

Share This Page