using any sim with ziphone

Discussion in 'Jailbreaks and iOS Hacks' started by djmoney4545, Mar 10, 2008.

  1. djmoney4545 macrumors newbie

    Joined:
    Jan 15, 2008
    #1
    if i want to use a iphone out of the us and i use ziphone to jailbreak unlock and activate it would i still need to use anysim to use any sim card or does the unlock do that in ziphone
     
  2. munroe macrumors regular

    Joined:
    Nov 14, 2007
    Location:
    Ireland
  3. bigbadnewill macrumors 6502

    Joined:
    Jun 6, 2007
    #3
    So does ZiPhone alter the bootloader then, making it possible to jailbreak even the newset iPhones (week 46 bootloader) with software only?

    I thought anysim was still required, if not then thats great :D
     
  4. munroe macrumors regular

    Joined:
    Nov 14, 2007
    Location:
    Ireland
    #4
    There's an option in ZiPhone to downgrade the bootloader. However this is not necessary to unlock the phone. A modified firmware from version 1.1.2 is used to accomplish the unlock.
     
  5. bigbadnewill macrumors 6502

    Joined:
    Jun 6, 2007
    #5
    So even with the newer bootloader you can still unlock all iPhones? I haven't been on the iPhone scene for a while, i just remember reading somewhere that the newer firmware made sure that you had to hardware unlock (ie use the TurboSim things)

    Sorry for being a little dense..like i said i've been off the scene of iPhones for ages, far too busy at uni :(

    And thanks for your reply, really appreciate it! :D
     
  6. munroe macrumors regular

    Joined:
    Nov 14, 2007
    Location:
    Ireland
    #6
    No worries. Uni is a good excuse.

    Yeah, they got around the problems that the new bootloader was causing. I used ZiPhone myself after updating to 1.1.3 with iTunes. (I don't need to upgrade to 1.1.4.)

    Sorry I should have said that it uses a modified baseband v4.2.13_G or something like that - the one that came with 1.1.2.

    There are a few concerns about replacing your bootloader which can fix some minor problems with the modified baseband. However if you downgrade the bootloader to 3.9, you can't go back. There's some concern that future hacks will need the 4.6 bootloader.
     

Share This Page