Using Chinese as system language but keep English as input language

Discussion in 'OS X El Capitan (10.11)' started by deranged58, Apr 13, 2016.

  1. deranged58 macrumors newbie

    Joined:
    Sep 14, 2010
    #1
    Hi, I'm trying to immerse myself in Chinese, so decided that I want to try using Chinese as the system language on my Mac. However, this changes quite a lot of things for my input. For example, keying in "'" changes to "‘" on many apps, even stock apps like iMessages.

    Also, I would like to switch back to using English for my default input in Word, but not sure how to do it.

    Does anyone have an idea? Thanks in advance!
     
  2. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #2
    The first problem is probably the automatic replacement of quotes. You can turn that off in System Preferences > Keyboard > Text > Use smart quotes and dashes. OS X itself offers automatic language detection when you type and it works in many applications. You can adjust that there also. As for default language in Word, you will have to check Word’s preferences.
     
  3. deranged58 thread starter macrumors newbie

    Joined:
    Sep 14, 2010
  4. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #4
    I am not sure if this help. Remove the Chinese keyboard from this page, then you will have no other keyboard to use but English.
    Screen Shot 2016-04-15 at 08.27.12.jpg
     

Share This Page