Using dd I'm getting a Resource Busy error

Discussion in 'macOS' started by JoshFink, Nov 10, 2007.

  1. JoshFink macrumors regular

    Aug 3, 2007
    Atlanta, GA
    Hello, I'm trying to restore an old Hard Drive image OS.dmg to a usb hard drive that I have.

    I'm using the command:

    dd if=/Users/Shared/OS.dmg of=/dev/disk5 bs=1m

    And I'm getting

    dd: /dev/disk5: Resource busy

    What would cause this error? I'm not sure why it's "busy"



    PS.. I get the exact same thing when i try to do it in DiskUtility
  2. mikehardy macrumors newbie

    Nov 10, 2007
    I just did this - what I did may work for you

    In order to overwrite all the information on the disk, you have to make sure the mac OS isn't using it first

    Open the, and on your USB hard drive, unmount any of it's partitions. Do not eject the USB hard drive.

    Right click on the hard drive in the DiskUtility and get it's Identifier from the Information tab.

    Now take your image, and the identifier, and put it all together with something like this, on the command line in terminal:
    dd if=<your image file> of=/dev/<disk identifier>

    That worked for me putting the diskboot.img bootable Linux image file onto a USB hard drive that had the identifier disk1 by doing dd if=/Users/mike/diskboot.img of=/dev/disk1

    good luck
  3. Ryan813 macrumors newbie

    Feb 8, 2008
  4. sbohonos macrumors newbie

    Sep 3, 2015
    Los Angeles
  5. Sarthak Varshney macrumors newbie

    Sarthak Varshney

    Sep 27, 2015
    thank you so much!
    it helped!!
  6. sem49 macrumors newbie

    Nov 30, 2015
    Well done. This just did the trick for me as well!
  7. No_GT31 macrumors newbie


    Apr 6, 2016

    Thank you!! it works for me!!

    i had to use "sudo diskutil unmount /dev/diskXsX" and then my dd worked!
  8. e.d.d.i.e. macrumors newbie

    Feb 5, 2017
    Worked great for me! Thank you very much. Been having trouble getting a live bootable USB created on a Mac. All good now though.
  9. iHateMacs macrumors 6502a


    Aug 13, 2008
    Coventry, UK
    11 year old thread still valid and useful today. Great. Thanks.

Share This Page