Mac Using Eclipse with macpro - intel


macrumors newbie
Original poster
Sep 18, 2006
I just got a new MacPro and am trying to get Eclipse up and running. I had no problem downloading and starting eclipse, my problem is being able to see the java source.
When i downloaded Eclipse, another java package came down but i was unable to open and install it, it kept on failing.
I searched all the java directories looking for the .java files and can not find them so i assumed I needed to download the JDK from Sun. But, there isn't one for the Mac.
Also, how do you open a .jar file on the mac, i used to use WinZip on the pc.
Thanks for your help,


macrumors 6502a
Jan 4, 2002
Austin, TX
See the Java source of what, Eclipse? Most likely that is a separate download.

As for the JDK they are included with Mac OS X except for v1.5 which is in beta right now, and you have to expressly download and enable it for default use by Java applets. But it is beta and Mac OS X has 1.4 and 1.3 already.

And if you install the Apple developer tools there are some Java-specific utilities for the command line.

For a UI app you can open .jar files with StuffitExpander (third-party app download). Go to and go through their wonderful download process (being a Windows user you are most likely familiar with the rigamarole).


macrumors newbie
Original poster
Sep 18, 2006
still having a problem

Hi, the sources that i am trying to see are the base Java code such as in java.lang.

I switched the jvm via Window > Preferences > Installed JRE

From the package Explorer: (select each of the following items in the hierarchy)
JRE System Library [jvm 1.4.2]
The Class File Editor shows up and says: Source not found...
You can attach the source by clicking Attach Source below:

If i changed the jvm to one which has the whole SDK why can it not find the source code for these classes?

Thanks, i am new to using java on a mac


macrumors regular
Jun 4, 2006
B-Town, India
There is a known issue with opening the Eclipse .dmg/tar with Stuffit; either it gives you an error or doesn't unpack everything. They recommend using the default unpacker in OSX (forgot what it's called, not on my mac).


macrumors 6502
Sep 15, 2006
Well when i installed eclipse on a 17" G4 pb as well as on a mbp (not mine though, waiting for c2d :cool: ) it worked out of the box - so if you just try to reinstall from the .dmg as was previously mentioned it'll hopefully work wonders :)


macrumors newbie
Original poster
Sep 18, 2006
In even bigger mess now

Hi folks, I am in even bigger mess now. I used to use Java on a Window's machine, never on a Mac. I can't believe this is so difficult. Its not supposed to be, i have a friend who also just downloaded eclipse and all was good.

after trying everything. I searched thru all the directories and got rid of Java 1.5 and 1.5.0 Since when i tried to unpackage the download it continued to say that I had a newer version on my machine.
What i deleted was from System > Library >Frameworks >Java>Versions.
I also deleted Eclipse.
I checked that under versions the current was pointed to 1.4.2

So, I downloaded Eclipse again, it would not open. Said it was missing the JRE. The version of Eclipse I downloaded was 3.2.

so, i went and downloaded the J2SE Release 4 from Apple site and tried to open it and it said that "a newer version was on the system"

I am totally lost here, I have looked at cache directories, computer directory which lists all versions for everything on the system and I can not find anywhere where 1.5 or 1.5.0 is hiding.

At this point, I don't know what else to do?? :( :(