Using Exchange - Contacts not up to date on Mac but work on iPhone

Discussion in 'OS X Mavericks (10.9)' started by simonmason, Oct 6, 2014.

  1. simonmason macrumors newbie

    Joined:
    Jul 21, 2013
    #1
    I have an Exchange (2010 SP2) Account setup on my my Mac (10.9.5) and various iPhones/iPads (8.02). On the iPhone/iPad the contacts folder is showing all of the contacts up to date. In Outlook (under Windows, web-based, and Mac) the Contacts are showing up to date. In Mac Contacts I see only about 10 (out of hundreds).

    However, I noticed that if I open one of the missing contacts anywhere but in Mac Contacts, then save it again - the contact shows up in Mac Contacts. Naturally I can open all of the contacts one by one and save them but I was hoping there was a way around this?
     
  2. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
  3. simonmason thread starter macrumors newbie

    Joined:
    Jul 21, 2013
    #3
    Not to the best of my knowledge - at least I did not intentionally share them. The only sharing I have in place in my Outlook is calendars.
     
  4. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    I don't know...I've got an Office 365 Exchange account that syncs contacts just fine in 10.9.5 Contacts as everywhere else. I haven't heard any similar issues as of yet. I'm wondering if it's a Exchange-to-Mac issue on the Exchange server, as Macs sync with Exchange in a different way from both Outlook for Windows and iOS.
     
  5. andrevaux macrumors newbie

    Joined:
    Dec 15, 2014
    #5
    I've seen this issue too. Seems it might be an issue with contact categories or something. Jolly annoying!
     
  6. andrevaux macrumors newbie

    Joined:
    Dec 15, 2014
    #6
    I've worked this out! (for me at least...)

    All/some contacts on OS X Yosemite not syncing from Office 365.

    Testing produces the following:
    If you edit a contact in OWA/Outlook 2013 this shows up in the Yosemite Contacts app.
    If you add a contact in Yosemite Contacts app this shows up in OWA/Outlook 2013.

    The problem might be that you've tried using “Outlook for Mac for Office 365” (Dec 2014). This seems to mess around with the contact categories which makes then non-viewable in the Yosemite Contacts app.

    The contacts are viewable normally in IOS, Windows etc.

    The trick to fix is to edit each contact and set and then clear a category. This needs to be done using “Outlook for Mac for Office 365”. If you try with Outlook 2013 this won’t fix the problem. You have to assign and clear categories in “Outlook for Mac for Office 365”.

    You can select all Contacts by using Option +A to select all, then right-click and assign category.

    Once you’ve done this your contacts will start appearing in Yosemite Contacts app again :)
     
  7. goosecasey macrumors newbie

    goosecasey

    Joined:
    Aug 13, 2015
    Location:
    Dallas, TX
    #7
    This worked for me. Thanks for the tip. It saved me hours of frustration rebuilding accounts
     

Share This Page