Using iPhone OTB 1.1.2 with old ATT/Cingular Sim

Discussion in 'Jailbreaks and iOS Hacks' started by davebc, Dec 18, 2007.

  1. davebc macrumors newbie

    Joined:
    Dec 17, 2007
    #1
    QUESTION:

    I'm on a business plan so therefore I can't use an iPhone on my current plan. I've heard somewhere that if I activate and jailbreak the new OTB 1.1.2 iPhone, then I can stick my old Cingular sim into the phone and use it without having to change my plan. Is this true? Or do I have to unlock it to use it with my old Cingular sim??? Thanks!
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
    Yup. Out of box iPhone 1.1.2 can be software jailbreaked / activated to use existing AT&T SIM cards. You don't have to SIM unlock (currently impossible).
     
  3. davebc thread starter macrumors newbie

    Joined:
    Dec 17, 2007
    #3
    So nothing else needs to be installed on it, I just activate and jailbreak it and I will be able to stick my old sim in there?

    Sorry for the excessive questioning, I just don't want to spend $400 on it if I can't use it.
     
  4. davebc thread starter macrumors newbie

    Joined:
    Dec 17, 2007
    #4
    If anyone could help me with this it would be greatly appreciated.

    Do I have to activate/jailbreak it a certain way to make it work with my old sim? Or if I just activate and jailbreak it will I be able to stick my Cingular sim from my other phone in it?
     
  5. Kenal0 macrumors regular

    Joined:
    Sep 15, 2007
    #5
    That is correct, Jailbreak and activate. You need to make sure you have a data plan. I am using the sim from my ATT Blackberry so the BB data plan covers it.
    Any unlimited data plan will work so if you currently have for example a Razr, you can add an unlimited plan and you should be fine. You will also have to add a text plan if you do not have one as well.
    Kenal0
     
  6. jside macrumors newbie

    Joined:
    Jan 10, 2008
    #6
    question

    if i also have an att sim card...do i have to downgrade to 1.1.1 then upgrade back to 1.1.2 with oktoprep in order to use my sim card?
     
  7. rlowe44 macrumors newbie

    Joined:
    Dec 31, 2007
    #7
    Just a warning; I have an OLD AT&T SIM card in an old Siemens phone, and it will not work in any iPhone. It also can't support a data plan. Call your local AT&T office and they can tell you if it will or not.
     

Share This Page