using iPhoto library with screen saver

Discussion in 'OS X Mountain Lion (10.8)' started by berlingoodman, Aug 31, 2012.

  1. berlingoodman macrumors newbie

    Joined:
    Feb 27, 2011
    #1
    Hi all,

    I just upgraded to Mountain Lion on a MacBook Pro from 2010 and an iMac from 2008. A funny thing happened. When trying to set up my screen saver preferences, it was no problem to choose "iPhoto" as the source for photos my Mac chooses from when screen saving. However, on my MacBook Pro this isn't an option. When I pick choose folder, my iPhoto library is greyed out and I can't select it.

    How can I get my MacBook Pro to allow me to use my iPhoto library with the screen saver, like my iMac is doing??

    Thanks all!
     
  2. aarmstrong27 macrumors regular

    Joined:
    Jun 20, 2012
    #2
    No help here. Mine is accessing it fine on my 2011 13" MBA.

    However, it can no longer find my cover art if I try to use that screen saver.

    Anyone with an idea on that one?

    OP-didn't mean to hijack your thread. Hopefully we can both get help. :)
     
  3. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #3
    Just to check, you have launched iPhoto since you upgraded, right? Sometimes the iPhoto Library will need to be updated and won't be available in System Preferences until that's done. You can also try repairing it if that doesn't work, by holding Command and Option while you launch iPhoto.

    jW
     
  4. berlingoodman, Aug 31, 2012
    Last edited: Aug 31, 2012

    berlingoodman thread starter macrumors newbie

    Joined:
    Feb 27, 2011
    #4
    Thanks for the tip, Mal. I had launched iPhoto after the update already but just tried repairing it. Still not seeing the folder in System Preferences. I also verified and repaired permissions in Disk Utility. Nothing. Maybe after a restart...

    Could it be that I have too many photos in my iPhoto? It's over 20GB's worth.

    Yes, aarmstrong, please ask your question in another thread. Thanks.
     

Share This Page