using iTunes with iomega NAS

Discussion in 'Mac Apps and Mac App Store' started by ttx336, Nov 27, 2011.

  1. ttx336, Nov 27, 2011
    Last edited: Nov 27, 2011

    ttx336 macrumors newbie

    May 29, 2011
    I just bought an AppleTV, I own an iomega NAS that I keep copies of my iTunes movies and TV shows on. I had hoped that turning on the media sharing in the NAS would allow streaming from the AppleTV but so far no joy. So, I went to another machine that runs Windows Server 2008 and is equipped with a Raid Card mapped as drive E: I installed iTunes hoping that I could "import" the movies and TV shows from the E: drive into iTunes and play them from the AppleTV but, again, no joy. I can copy the actual files into the C: drive and play them but that drive is very small as it is intended for the OS only so this is not a viable solution. When I try to "Add folders" for a movie it works fine and the movie shows up in iTunes, I cannot get TV shows to do the same nor can I "Add files" and get it to work. Even though the movies show up in the iTunes library on the Server machine, when I go to the AppleTV, it says that there are no movies in the Server's iTunes.

    Perhaps I should also mention that iTunes complains that QuickTime is not installed when I work with iTunes in the Server machine and it also warns me that there is no soundcard.

    When I stream from this MBP, it all works fine but I was hoping to be able to stream without having to open the lid on this machine and start iTunes, if I have to do all of that I might as well have saved the $99 and just continue to plug in the HDMI cable and run from this machine. Surely there must be a way to stream from the NAS or the Server machine...???

    Edit: I was doing some poking around on the AppleTV and saw a network test function, I signed in and it did't work the first time, I signed in again and it worked the second time. After that I was browsing around and saw that my TV shows that I own now appear under "Purchased" in the TV Show section so that appears to be solved now since I appear to be able to stream them, I guess, from the Store?? not sure, but, it works.

Share This Page