Using monitor in clamshell mode w/ XP and Boot Camp

Discussion in 'MacBook Pro' started by delavagus, Aug 27, 2008.

  1. delavagus macrumors newbie

    Joined:
    Aug 27, 2008
    #1
    Is there any way to do it?

    I have a brand new MBP with Leopard. I installed XP Pro on it. Clamshell mode works perfectly in Leopard: I can close the lid, wake up the computer with an external keyboard, and my external monitor clicks on. But I can't get clamshell mode to work under XP. After doing some research, I've tried the following:

    (1) I tried "mirroring" the two monitors (i.e., the built-in and the external monitors), then telling XP to "do nothing" when I close the lid (i.e., not to go to sleep). That didn't work. There is no way to set the external monitor to act as the primary monitor; the option is "grayed out" on the display settings page.

    (2) After loading Leopard in clamshell mode, I tried restarting the computer into XP. I hit restart, held down the option key, but it didn't work. The computer sat there as if suspended. When I opened the lid, it immediately gave me the "welcome" screen in XP.

    Any advice? If I can just get this to work, my new MBP will officially earn the title Best Computer Ever.

    Thanks!
     
  2. Eddyisgreat macrumors 601

    Joined:
    Oct 24, 2007
    #2
    Check again. You should be able to do this by selecting "extend the desktop onto this monitor" on the external monitor, then tell it that its your main monitor, then choose the internal lcd and deselect "extend the desktop"...

    AFAIK, Apple's implementation of wkst(clam) mode isn't as robust/elegant in Windows as it is in Leopard.
     
  3. delavagus thread starter macrumors newbie

    Joined:
    Aug 27, 2008
    #3
    Thanks for the reply!

    Nope, the option is definitely grayed out. I'm on the machine right now, in XP, both monitors on -- there's no way to set the external as the primary. The "primary monitor" options are grayed out for both monitors: I can neither deselect the built-in monitor, nor select the external.

    Maybe I have to change a different setting in order to be able to change the primary-monitor setting?
     
  4. e12a macrumors 68000

    e12a

    Joined:
    Oct 28, 2006
    #4
    try downloading drivers from http://www.laptopvideo2go.com/

    make sure you download one thats been tested and the consensus is that its good. Also check for the right version.

    I had the same problem. the bootcamp drivers that came with the Leopard disc are no good.
     
  5. delavagus thread starter macrumors newbie

    Joined:
    Aug 27, 2008
    #5
    I installed the latest nVidia drivers. It doesn't make any difference: I still can't select my external monitor as the primary monitor.

    Now I'm wondering if this is an XP issue, or a Boot Camp issue, or some combination of the two? Should I be trying to solve this problem on Windows message boards?
     
  6. e12a macrumors 68000

    e12a

    Joined:
    Oct 28, 2006
    #6
    its a driver issue for me at least. It frustrated me so much.

    but i was using Vista at the time, so i'm not sure if XP is any different.
     
  7. delavagus thread starter macrumors newbie

    Joined:
    Aug 27, 2008
    #7
    I figured it out.

    It wasn't a Mac/Boot Camp issue at all, as I had (foolishly, perhaps) assumed. No, it's a Windows issue. In case anyone else runs into the same problem using Windows via Boot Camp, here's how I solved it:

    I could not set my external monitor to function as the primary monitor using the normal method, i.e., through accessing the display properties. The option to set the external monitor to primary is greyed out. (In fact, it's STILL greyed out, only now the monitors have switched positions.) I had to use nVidia's control panel.

    1. Go to nVidia Control Panel.
    2. Make sure you're on "Advanced Settings," not "Standard Settings." (This is key!)
    3. Go to "Set up multiple displays," under "Display" on the left-hand menu.
    4. Set (1) to "Only use one display (Single)."
    5. Set (2) to the external monitor.
    6. Number (3) is an option to set which monitor is to serve as primary. This is greyed out. But if you choose the external monitor in (2), then it will automatically switch to the external monitor in (3).
    7. Click "Apply."

    The first time I did this, it didn't work. Rather, it worked initially, during the "Preview" period, when a pop-up window says the computer will revert to the prior settings in 10 seconds (or whatever) unless you click OK. For those 10 seconds, I had the external as the primary, but when I clicked okay, the built-in monitor flashed and then went dark and the external reverted to the secondary monitor, i.e., the built-in monitor was off, but the external was still the secondary.

    Frustrated, I tried again, and this time it worked. I'm now typing on an external keyboard, running XP on a MBP, with the lid closed, using an external monitor. Yah!

    IMPORTANT: Unless you change the power settings, closing the laptop lid will still put the computer to sleep even if the external monitor is the primary monitor. Go to Control Panel -> Power Options -> Advanced. Under "Power Buttons," switch "When I close the lid of my computer..." to "Do nothing." Then when the lid is closed, the computer will stay on and you can use the external monitor.
     
  8. Newboy123 macrumors newbie

    Joined:
    Sep 8, 2008
    #8
    Problems

    delavagus:

    Im running a macbook
    2GHz Intel Core 2 Duo
    4 GB 667 MHz DDR2 SDRAM
    320GB HD

    Bootcamp XP PRO x32bit

    I am having problems with getting the Clamshell mode to work in windows xp pro mode. Like everyone else Running it in Leopard is Great and Perfectly works on my 24" External Monitor. I've tried downloading nVidia Control Panel but cant seem to download what I need and whatever it is I'm downloading, nForceware or something won't install. I'm assuming its because I'm on pro. If your method is fool proof can you put up the appropriate links I need to get the right software for the Job. Thanks
     
  9. Eddyisgreat macrumors 601

    Joined:
    Oct 24, 2007
    #9
    it was fustrating at first but I did essentially the same thing for bootcamp.

    now I can restart into Windows with wireless bluetooth keyboard and mouse & have it drive in lid-closed mode (in xp).

    Do what the poster above did. You may have to update your drivers through Apples Bootcamp software update.

    After this (or prior too even) you should have access to the nvidia control panel.

    Configure to your liking, but of course what you will want to do is enable the external monitor to run only, so your internal display is closed.

    After this you should be able to shut down, power up and close your lid.

    Once you do this, Windows will load on your internal display. If your lid is closed like it should, you'll see the Apple logo light up for a little while. This is normal.

    Once it has loaded, it will power down the internal LCD and switch back to your external.

    Works flawlessly for me. Once i'm done, just reboot and hold option to go back into OS X :)

    BTW, I too have Windows Xp Pro. Who uses home anymore?
     
  10. delavagus thread starter macrumors newbie

    Joined:
    Aug 27, 2008
    #10
    You should have nVidia Control Panel installed automatically. You should NOT have to go looking for it online. In the system tray (bottom right, beside the clock), you should have an item that, when moused over, says "NVIDIA Settings." Right-click on it, and you should see "NVIDIA Control Panel" in the menu that pops up.

    If "NVIDIA Settings" is NOT in the system tray, I don't know what to tell you, besides reinstalling XP. Does Bootcamp have any sort of "Repair" options? Or maybe a software update would take care of it.

    Hope this works.
     
  11. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #11
    Or in Windows you can just select which one is the primary in the regular display setting when you right click on the desktop and select Properties.
     
  12. delavagus thread starter macrumors newbie

    Joined:
    Aug 27, 2008
    #12
    Actually, no, you can't, at least not using a MacBook or a MacBook Pro with the nVidia card. The problem is discussed above.
     
  13. Markov macrumors 6502

    Markov

    Joined:
    May 18, 2007
    Location:
    Philadelphia
    #13
    Strange

    Hmmmm... I normally never use clamshell mode because the heat of the MBP is dispersed through the keyboard mainly which is not good for the screen. Anyway, I have always been able to set my external monitor to be the primary one, and the only one on. I right click, go to nvidia control panel. I go to the "set-up multiple screens" and it let me chooses the external one as the primary and shuts the MBP screen off. This should work with Apple's drivers as well as laptopvideo2go drivers. I have never tried using clamshell mode in XP, but I would assume just close the lid, hit a key on the keyboard and it should keep the correct monitor on and the MBP monitor off.
     
  14. lowfat macrumors newbie

    Joined:
    Aug 24, 2007
    Location:
    Grande Prairie, AB, CAN
    #14
    Sweet. Thanks. Same problem here. Pretty easy fix if you know what you are looking for.
     

Share This Page