Using space key to uncheck 'Reopen windows when logging back in'

Discussion in 'Mac OS X Lion (10.7)' started by cubex, Oct 17, 2011.

  1. cubex, Oct 17, 2011
    Last edited: Oct 17, 2011

    cubex macrumors member

    Jun 8, 2009
    Hey all,

    Just wondering if anyone knows what I need to do to enable using the space key to uncheck 'Reopen windows when logging back in' when restarting in Lion? I can do this on my 2010 MacBook Air that was upgraded to Lion from Snow Leopard as well as my Parents MacBook Pro that was also upgraded to Lion from Snow Leopard.

    On my 2011 MacBook Air that came with Lion I can't seem to enable this functionality - if I enable Full Keyboard Access for All Controls in the Keyboard > Keyboard Shortcuts preference pane it will work for that restart only, after it's back up and running if I try to restart it again I can't use the space key on that dialogue although the Full Keyboard Access setting is still set to All Controls. I've even tried doing a fresh install of 10.7.2 and the issue still presents itself in the described fashion.

    Any ideas? This is driving me up the wall.. Thanks in advance.
  2. UncleEk macrumors newbie

    Nov 15, 2011
    I second this. Let's just hope someone can fix for us.
  3. xgman macrumors 601


    Aug 6, 2007
    Why Apple doesn't allow you to reverse this behavior is beyond me.
  4. MartiNZ macrumors 65816


    Apr 10, 2008
    Auckland, New Zealand
    Not sure about the space bar issue; maddening that that preference should be not saving, as it is a nice timesaver.

    I'm also still at a loss as to how this inability to choose made it into release, let alone persisted through two point point updates and I imagine will thrive through several more. I simply cannot think of a time when I would -ever- want to enable resume; apart from anything else, when one restarts, it tends to be in order to get a fresh start!

    Then again, I also still can't think of any time I would -ever- want every little change to a file saved without my say-so, and then not be allowed to save on my terms. Nevermind /rant.
  5. isoMorpheus Guest

    Jul 29, 2007
    I third that. It's strange, I have this lurking sense that there is a setting somewhere about this in the Universal Access pane, but I couldn't find it.
  6. szolr macrumors 6502

    Jul 27, 2011
    London, UK
    I checked all over System Preferences, but couldn't find anything either. :(
  7. isoMorpheus Guest

    Jul 29, 2007
    Here's my case, I think it has something to do with the threat starter's point. I have a 2010 MacBook Pro which was upgraded from Snow Leopard to Lion. I've been able to use the spacebar to uncheck the box since the upgrade. But recently I did a clean install on my Mac and lost this ability.
  8. drummwill macrumors newbie

    Mar 30, 2009
    got my early 2011 15" mbp with lion already installed
    i've always been using space to uncheck it never had a problem
  9. dpreuss macrumors newbie

    Sep 19, 2010
    I use control+eject, space, enter. The only change I can remember making in preferences is enabling access to assistive devices in the Universal Access. I'm not sure if they are related or that's just how my 10.7.2 Late 2011 MBP worked from the box.
  10. isoMorpheus Guest

    Jul 29, 2007
    I know there are many good reasons why the box should be checked, but then sometimes it's just better to leave it unchecked. I've tried a bunch of crazy things to see if I could toggle this feature back but have had no avail. So, I just emailed Tim Cook about this. Let's see how good of a CEO he is.
  11. flori72 macrumors newbie

    Oct 24, 2011
    Exactly the same for me.
  12. xgman macrumors 601


    Aug 6, 2007
    I can't think of 1. Maybe we should do a poll and submit it to Apple.
  13. isoMorpheus Guest

    Jul 29, 2007

Share This Page