Using tv as monitor

Discussion in 'MacBook Pro' started by R6Seven, Dec 9, 2008.

  1. R6Seven macrumors member

    Joined:
    May 25, 2008
    #1
    I'm trying to connect my 15" Santa Rosa MBP to the 40" Samsung TV (1080p). For the time being, I have it connected through a DVI-VGA converter to the VGA input on the back. Audio is done though the standard aux cable going out from my headphone jack in the MBP.

    I seem to have trouble reaching the full resolution on the TV. The max I'm getting is 1280x1024 (60Hz). Is there any way I can reach 1920x1080 on my TV screen? I'm completely lost. Is it because the VGA doesn't support any more than that? Or could I be using a bad DVI-VGA converter? Please help.

    Thanks.
     
  2. drichards macrumors 6502a

    drichards

    Joined:
    Nov 30, 2008
    #2
    I believe the maximum resolution the MBP will push thru VGA is 1600x1200, and that doesn't help things. Does your TV have a DVI input, or HDMI? You'd be best off with either of those imo.
     
  3. sal macrumors 6502

    Joined:
    Oct 13, 2007
    #3
    don't pass it through a dvi-vga adapter. Get a dvi-hdmi. You will get full resolution this way.

    Oh and by the way, when you do this, it's worth mentioning that for some reason(at least in my case) I was getting 1920x1080(interlaced) resolution even though my samsung supported 1080p. the text looked a little funky running at interlaced resolution.

    1920x1080(interlaced) was the only thing available in the display settings. Had to turn on show displays in menu. by some "miracle" the 1920x1080 (60hz) option was available through the menu but not through the display settings. Go figure.
     
  4. R6Seven thread starter macrumors member

    Joined:
    May 25, 2008
  5. Tomorrow macrumors 604

    Tomorrow

    Joined:
    Mar 2, 2008
    Location:
    Always a day away
    #5
    Make sure your TV is LCD and not plasma - I've read of many instances where someone created burn-in on a plasma from a computer or video game console.
     
  6. drichards macrumors 6502a

    drichards

    Joined:
    Nov 30, 2008
    #6
    That's old hat. New plasmas made in the last three years don't have burn-in problems after the first hundred hours, and you can correct it with this for free 90% of the time if you do experience burn.
     
  7. milk242 macrumors 6502a

    Joined:
    Jun 28, 2007
    #7
    When I connected my SR MBP to my 40" samsung lnt-4061f, I had to use a different refresh rate setting. The default is 60hz, but I had to change it to 59.9hz to get it to display to full resolution.
     
  8. sal macrumors 6502

    Joined:
    Oct 13, 2007
    #8
    I'll show you.

    The first screen capture below is the display preferences. Notice there is only the option for 1920x1080(interlaced) [1080i] and there is no option for 1920x1080? [1080p]

    the 2nd capture is through the display icon on the menu bar, which you have to enable in the display preferences. Here I have two options: 1920x1080(interlaced - 0hz) and 1920x1080 (60hz)

    selecting the 1920x1080 (60hz) option improved how the screen looked and the samsung is reporting it as 1080p, which is what I wanted because the text looked really bad at 1080i

    Not saying you'll have the same problem, but just in case you do, You'll know the solution.

    btw, I have a 37" samsung
     

    Attached Files:

  9. R6Seven thread starter macrumors member

    Joined:
    May 25, 2008
    #9
    sweet. thanks a lot for that last reply sal. i'm going to try that as soon as i get the chance.
     
  10. Shawn Parr macrumors regular

    Joined:
    Oct 31, 2008
    #10
    I've had this same thing happen on two Samsung TVs. A 69 series and a series 750. So the OP probably will as well.

    R6Seven, if you haven't seen it already, check out monoprice.com for DVI-HDMI cables. You have to wait for the shipping, but the cost/performance is insanely good.
     

Share This Page