Using utorrent on an iBookG4

Discussion in 'PowerPC Macs' started by Adam Woodhams, Feb 18, 2011.

  1. Adam Woodhams macrumors newbie

    Joined:
    Jan 20, 2011
    #1
    Hi, i've tried a fair few torrent programs to use on my iBook, and I can download and install them, but I can't use them to open a torrent/start a download. Can anyone help? Thanks.
     
  2. mulo macrumors 68020

    mulo

    Joined:
    Aug 22, 2010
    Location:
    Behind you
    #3
  3. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #4
    I believe that 1.54 is the last version that will run on PowerPCs.
     
  4. zen.state macrumors 68020

    zen.state

    Joined:
    Mar 13, 2005
    #5
    Wrong. 1.54 is the last version to run on 10.4. All current builds still fully support PowerPC. I am running the 2.20b3 beta right now on PowerPC.

    All most developers have to do to support PowerPC is check that box in xcode and the app is universal. It's really only game developers that have to develop both separately.

    Not sure why people just assume PowerPC is ignored now. Even 5 years into the Apple/Intel partnership now I can guarantee there are still many more PowerPC macs out there.

    If you do a bit of googling you can easily see how short a life many of these intel macs have. Some die before their 3rd birthday for goodness sakes.
     
  5. mabaker macrumors 65816

    mabaker

    Joined:
    Jan 19, 2008
    #6
    True words. I have to say tho that the Intel Mac Minis are solid gold, tho. Very reliable.
     
  6. Rodus macrumors 6502a

    Rodus

    Joined:
    Oct 25, 2008
    Location:
    Midlands, UK
    #7
    Try Bits on Wheels, its not supported now but its great on old PPC Macs.
     
  7. jchase2057 macrumors regular

    Joined:
    Dec 6, 2010
    Location:
    Detroit
    #8
    i'm running the latest transmission on my g4 ibook 800
     
  8. Hrududu macrumors 68020

    Hrududu

    Joined:
    Jul 25, 2008
    Location:
    Central US
    #9
    Probably the most reliable of Intel Macs, but I happened to get a bad one. Graphics chip is hosed and screen artifacts and jumps all over the place when you move the curser. :(
     
  9. Adam Woodhams thread starter macrumors newbie

    Joined:
    Jan 20, 2011
    #10
    Does anybody have a clue why utorrent or any other torrent program won't work on my ibook G4? It installs and loads, but won't recognise torrents to download.
     
  10. jchase2057 macrumors regular

    Joined:
    Dec 6, 2010
    Location:
    Detroit
    #11
    Sounds like human error. If you have transmission installed already drag a torrent file into the transmission window. Or right click>open with>transmission. This will bring up a list with all the files in the torrent. uncheck the ones you dont want and click ok. When its done the progress bar will turn green
     
  11. lvlarkkoenen macrumors regular

    Joined:
    Apr 21, 2011
    Location:
    Utrecht, NL
    #12
    It appears, though, that they didn't check that box for 2.31, as 2.22 appears the last one that runs on 10.5 with PowerPC.


    I'm running 10.4 and didn't really know a torrent client that works on it. I stopped searching quite soon though :s. Gonna give Transmission 1.54 a try now :) Thanks for the info.
     
  12. raysfan81 macrumors 6502a

    raysfan81

    Joined:
    Oct 6, 2009
    Location:
    North Carolina
    #13
    Transmission is great I use it on my Macs and on my computers running Ubuntu. The current version is 2.31 which is 10.5+ Intel only, but the old versions are very similar and support PPC.
     
  13. zen.state macrumors 68020

    zen.state

    Joined:
    Mar 13, 2005
    #14
    I see they just dropped PowerPC support. The last PPC version then is 2.22 but it needs 10.5 which I run on my G4 tower. As I noted in my above post 1.54 is the last version to run on 10.4.

    One of the many roles my G4 tower fills for me is a bit torrent machine. Transmission is one of the leading clients when it comes to encryption so it's already far more advanced than many. I will use 2.22 till it stops working well enough. Vuze (azureus) would be my second choice and it's still coded for PowerPC.
     
  14. Badrottie Suspended

    Badrottie

    Joined:
    May 8, 2011
    Location:
    Los Angeles
    #15
    Wow you made me proud of you!!
     

Share This Page