Using your Mac for phone calls - how to avoid mic feedback from speakers?

Discussion in 'Mac Basics and Help' started by BeatCrazy, Nov 13, 2015.

  1. BeatCrazy macrumors 65816

    Joined:
    Jul 20, 2011
    #1
    Hi all,

    I like this Yosemite/El Capitan feature, but I'm having a hard time getting it to work well. I have both a Mac mini and Mac Pro 2013, situated about 6 feet from my monitor/speakers. I ran a mic to my monitor area and have successfully used this feature. However, the mic always pics up the sound from my PC speakers situated on either side of the monitor.

    Short of using headphones, do you have any tips on how to place a microphone to avoid the speaker sound feeding back into the mic, which frustrates the person on the other end of the conversation?
     
  2. ApfelKuchen macrumors 68020

    Joined:
    Aug 28, 2012
    Location:
    Between the coasts
    #2
    First, are you sure the external mic is the selected audio source? System Preferences > Sound > Input

    You have all the classic ingredients for feedback, and have given far too little information for anything more than a general answer. How loud are the monitors? What is the polar pattern, sensitivity, gain setting, and placement of the mic (proximity to the person speaking)? These are all variables that affect feedback, in any amplified sound situation.

    I'm going to assume that speaker volume is at the level you desire, so "turn down the speakers" is probably a non-starter. You don't want to dive for the volume every time a call comes in, any more than you'd want to wear headphones all the time.

    A mic placed in front of the speakers is always a feedback-prone configuration. All you can do is try to ensure that the mic picks up substantially more spoken voice than sounds from the loudspeakers. The farther the mic is from the voice, the harder that is to accomplish. An omnidirectional mic that is the same distance from the speakers as it is from the person speaking is a recipe for disaster. A directional (cardioid/uni-directional) mic pointed towards the person speaking (and pointing away from the loudspeakers) improves the situation. A closely-placed mic (headset mic) is the generally preferred setup.

    The feature has worked very, very well for me, within the confines of an Apple-controllable situation (built-in speakers and built-in mic on a 27" late 2013 iMac). They've clearly done their homework for that configuration.
     
  3. BeatCrazy thread starter macrumors 65816

    Joined:
    Jul 20, 2011
    #3
    Yes, the external mic is the source. The setup does work, just the person I'm talking to can hear their own voice as a result of the speakers being relatively close to the mic. The monitors are not loud, just average PC speaker volume, for a phone call. The mic is an Audio Technica ATR4650, and yes, it's probably the same distance away from my head, as it is from the speakers.

    I understand that a headset + mic would probably work, but I'm curious as to how people with current Mac desktops get this to work with standard equipment, i.e. everyone probably has some speakers.
     
  4. ApfelKuchen macrumors 68020

    Joined:
    Aug 28, 2012
    Location:
    Between the coasts
    #4
    I think you'll find that the vast majority of Mac users are using the internal speakers and mic; headphones are probably the #2 configuration, external speakers #3. (There are far fewer Minis and Mac Pros than MacBooks and iMacs).

    For that particular mic, go with the lapel clip or the monitor mount - don't leave it somewhere between. Here's the thing... Presuming the speakers are on roughly the same plane as the front of the display (flanking), then a display-mounted mic will likely pick up less sound from the speakers than it if it was placed a foot or two in front of the speakers. While low frequency radiation from speakers tends to be fairly omni-directional, mid- and high-frequency sound radiates more directionally, and most feedback comes from mid- and high-frequencies. That leaves the front of the display in an upper-frequency dead spot. And if the speakers can be placed a few inches in front of the display, so much the better.

    Now, you'll have to project your voice more if the mic is display-mounted than if it was on your lapel, but convenience may trump optimal placement.
     
  5. BeatCrazy thread starter macrumors 65816

    Joined:
    Jul 20, 2011
    #5
    I appreciate the input ApfelKuchen. After playing around with it a bit more today, I think I'm going to give up on external mic/speakers for phone calls and use my Plantronics Voyager Legend BT headset.
     
  6. campyguy macrumors 68030

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #6
    A recommendation? Buy the BT300 USB dongle - either the standard version or the Microsoft version, depending on which apps or softphone you're using - essentially converting your Legend setup to a Legend UC setup. You'll get the 1.6 HFP BT profile - wideband audio - on your Mac/PC.

    I have an Edge UC setup, and I can really tell the difference when I'm using the Edge without the BT300 in my Mac - it's like night and day in Skype, dictation mode, or my softphone - no more "what did you say?" on the other end. The BT300 works with both the Legend and the Edge, and the dongle can be purchased separately from Plantronics or from Amazon/Staples. Cheers!
     
  7. BeatCrazy thread starter macrumors 65816

    Joined:
    Jul 20, 2011
    #7
    I actually had the Voyager Legend UC kit, which includes the BT300. I never bothered setting up the dongle, I figured the built-in BT connection in the mini was good enough. I did a firmware update on the Legend yesterday to 1.07 and it said it includes support for wideband audio. Are you saying there's still room for improvement if I use the BT300?
     
  8. campyguy macrumors 68030

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #8
    Absolutely, there's a huge improvement with the correct version of BT300. Our Macs don't have the BT 1.6 HFP profile "built in". That dongle provides the BT 1.6 HFP profile interface for our Macs, plus the proper vocoder for the app(s) we're using. If you're not using the dongle with your Mac, you're not getting wideband capability with your headset and your Mac/apps. Stop reading this post now, and do it, then come back... I'll wait. :D

    Do do do do do do, do do doo, do doo doo do doo do...

    If I use my Edge with my Mac, which I can - I often get the "Wut?" "Can you repeat that?" and "You sound really bad today, is it a bad connection?" comments when I'm using my Edge with my Mac. Dial in the dongle, I've never had a complaint. I get lazy sometimes, using my Edge with my iPhone and the calls sound great, then I forget to put the dongle in my rMBP when I get back to the office and make a Skype call that doesn't sound so great - get the dongle, plug it in and pair it, and all of a sudden things are good again with my Edge and Mac.

    The only "issue" with the dongles, and it's likely not an issue with us, is that there's two models - one for most applications, and there's one for MS Lync (now Skype for Business) and other MS apps. It's about the built-in vocoder that's embedded in the BT300's firmware. There's plenty of crappy reviews on Amazon's and Plantronic's from dippos that didn't read the directions about which one to choose. Even after a few years or so, if you have the incorrect dongle, Plantronics will happily make a swap - their CS is awesome.
     
  9. BeatCrazy thread starter macrumors 65816

    Joined:
    Jul 20, 2011
    #9
    I appreciate the input. I set up the dongle, made sure I was using Multi-output device with the BT300 as the one of the outputs, and it for the input. Speaker test in System Preferences Audio sub-menu works, but I can't hear audio and the headset doesn't transmit voice.

    I'm 99% sure the problem is because my Plantronics kit is the "Optimized for Microsoft Lync", which I got via work.

    So you think I should email (call?) them and as them for a Mac-compatible BT300?
     
  10. campyguy macrumors 68030

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #10
    Absolutely, give Plantronics a call. FWIW, both dongles are Mac-compatible - your issue is likely due to the apps you're using; the BT300M is likely the one you're using - that's the one that most MS-based apps use. Keep in mind that it's the vocoder that's giving you grief - it's like "why doesn't my MS Mouse work with my Mac?", it's because of the proprietary drivers that are embedded in the dongle that ships with that MS Mouse.

    I have both dongles, since I have a Mac and a Windows PC on my desk - I have them color-coded so I don't mix them up! FWIW, Plantronics does sell them separately - I prefer that option since, for $50, I have all of my bases covered. I always use the BT300 Standard unit with my Mac, but I don't use Skype for Business with my Mac. I've never seen an "updater" or "conversion" option.

    Just to be on the safe side, and to not waste your time, make sure you take the time to properly pair the BT300 you have in the Sound Preference Pane - you should make sure it's "paired", and not your Voyager - your Voyager will port data through the paired BT300. When I have my Edge powered, and my BT300 powered, I will see both in the Sound Pref Pane - but only get HFP 1.6 when the BT300 is the selected Input/Output device.
     
  11. BeatCrazy thread starter macrumors 65816

    Joined:
    Jul 20, 2011
    #11
    I unpaired the Voyager before I started setting up the BT300. It is the only thing I see in the Sound Preferences pane. Technically it's showing as Plantronics BT300M as part of my multi-output devices (under Audio Devices in MIDI setup), and it's the only sound input. I also have an option in Input setting for USB audio CODEC, but that is unselected in favor of the 300M.
     
  12. BeatCrazy thread starter macrumors 65816

    Joined:
    Jul 20, 2011
    #12
    Talked to Plantronics, after some negotiations, they're going to send me a standard BT300. Fingers crossed!
     
  13. BeatCrazy thread starter macrumors 65816

    Joined:
    Jul 20, 2011
    #13
    Well I did get a standard BT300 in today. Was messing around and thought I got it working, was getting test tones through the headset, and even ringing when dialing. But I could not hear the caller, and they could not hear me. So I started from scratch to create an aggregate audio device.

    My setup is very simple, I have external speakers connected via optical out. Those can be turned off during phone calls. Just trying to get the BT300 to work for phone calls made from the Mac via iPhone. FaceTime Audio does not work either.
     

    Attached Files:

  14. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #14
    Bluetooth in ear headphones, preferably the ones that go behind you neck so you look good on video!
     
  15. BeatCrazy thread starter macrumors 65816

    Joined:
    Jul 20, 2011
    #15
    Yeah, I got a Plantronics Voyager + BT300 dongle. In the post right above yours, I show a screen shot. I cannot get this combo to work :(
     
  16. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #16
    Then go into System Preferences-Sound panel and select the heap hones or go really blow your mind just hold down the 'option' keyboard key while clicking the sound symbol in the Finder menu and then select the sound output!
     
  17. BeatCrazy thread starter macrumors 65816

    Joined:
    Jul 20, 2011
    #17
    Yeah, I tried that. Not sure if you saw my screen shot above? I can get the test tone sound through the headset, but I don't get sound or mic activity for actual calls on the Mac (made via iPhone, of course).
     
  18. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #18
    Well try then to Reset Your PRAM to see if it helps!
     
  19. BeatCrazy, Nov 24, 2015
    Last edited: Nov 24, 2015

    BeatCrazy thread starter macrumors 65816

    Joined:
    Jul 20, 2011
    #19
    Good reminder tip. I tried that, no difference. I also tried installing the Plantronics Hub for Mac application, but no change.

    Just to clarify: The headset does connect to the dongle. I can hear "PC connected" from the headset. The configuration is shown above. Also, the calling to/from the Mac does work, as I can hear everything via my normal speakers when making/receiving a call. Just nothing from the Voyager Legend headset. And I tried this same headset with a phone, works as expected.

    Something is crazy with the VoIP protocol that OS X uses, I think.

    EDIT: I can get the headset to work for all calling when I pair it directly to the Mac. Sound is very mediocre, as to be expected. So my issue is just integrating the BT300. Once I add it into the mix, I can't hear/send audio from the headset, even though the headset pairs with the BT300.
     
  20. BeatCrazy thread starter macrumors 65816

    Joined:
    Jul 20, 2011
    #20
    FINALLY! Got this thing to work. Maybe someone else can benefit from my headaches. After installing the Plantronics Hub software, attached is a setting I had to change to Yes. Now, everything works! Be sure and set the FaceTime "Video" menu to use the BT300 for both Microphone and Output.
     

    Attached Files:

  21. campyguy macrumors 68030

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #21
    I'm pleased that this dongle is working out so far, and that you caught the setting change. One more setting you can play with is in the Hub app's Settings Pane, in Software Settings - the "Headset to PC Audio Link" setting, which is set to "Active Only During Call".

    I changed my BT300's setting to "Active Always", as I only use the BT300 for calling and dictation on my Mac and, especially for dictation, I found that some of my speech was clipped by the speech-sensing sensor/link in my devices - changing to Active Always remedies that 99% of the time. You might find this Setting change helpful.

    I also find that my dictation accuracy goes way up if I leave Active Always on so I just leave it on whenever the dongle is plugged in. I dictated this response using the Edge UC combo with my Mac. Cheers!
     
  22. BeatCrazy thread starter macrumors 65816

    Joined:
    Jul 20, 2011
    #22
    Good tip, I played around with that.

    Here's my last question, I think. With these settings (screenshot) everything is working as expected, for calls, audio playback etc. EXCEPT, that the headset plays back all audio from the Mac. Is there any setting to prevent this, i.e. only play back call audio? Or do I just need to turn the headset off except for calls?
     

    Attached Files:

  23. campyguy macrumors 68030

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #23
    I'll admit to not having found a decent solution for what you, we - rather, are looking for here. My "fix" is in the User & Accounts and Sound Pref Panes.

    In the User & Accounts Pref Panes, I work in a Standard User Account that's set up for my desired activity, in my work-related Account there's no iTunes or play stuff set up - start-up Login Items like the iTunes Helper are deleted, for example.

    It's in the Sound Pref Pane that I've tweaked my workspace a bit. I have the Menu Item (Show Volume in Menu Bar) enabled, so I can switch Input/Output sources quickly. Under "Sound Effects", they're set up to play through my rMBP's Internal Speakers and I generally keep the Alert Volume and Output Volume here way down or muted; I disable both "Play user interface sound effects" and "Play feedback when volume is changed" options.

    I've had limited-to-no success creating a MIDI device that satisfies my wants. It's a slow weekend, and deep snow is keeping my friends and family away this long weekend (yes, more football for me!), and I've considered trying again - if I come up with a profile I'll update this thread! Cheers!
     

Share This Page