Uspeed USB 3.0 Hub sleep issues

Discussion in 'iMac' started by yanksno1, Mar 12, 2013.

  1. yanksno1 macrumors newbie

    Joined:
    Oct 11, 2012
    #1
    I have been experiencing sleep issues (really waking from sleep) when my USB 3.0 Hub has been plugged in. I bought the Uspeed USB 3.0 7 Port Hub for my late 2012 iMac. If I leave my iMac and let it go to sleep for an extended period of time (usually 3-8+ hours) when I return my screen freezes for about 30+ seconds or so, after that everything works fine. If I unplug the hub, everything works fine and starts up instantly. So obviously it's the hub. Any ideas?
     
  2. Ddyracer macrumors 68000

    Ddyracer

    Joined:
    Nov 24, 2009
    #2
    Read somewhere that apple doesnt support usb 3 powered. I think its a driver issue but don't take my word, just throwing some ideas your way.
     
  3. MeFromHere macrumors 6502

    Joined:
    Oct 11, 2012
    #3
    It's NOT obvious to me that "it's the hub". You didn't specify what (if anything) is plugged into the hub. The problem could be in Mac OS, the iMac USB hardware/firmware, the hub, or any of the devices connected to the hub or other USB ports on the iMac. All the parts of the USB system interact. USB is notoriously fragile, and robust implementations are pretty rare. Typical industry practice is to get it working just well enough to pass Windows acceptance tests, then ship it.

    Have you contacted the Hub manufacturer's tech support? Apple support? They are probably equipped to explain to you how to gather useful diagnostic data that might isolate the cause of the problem.

    For what it's worth, I have the same hub, connected to a 2012 iMac. I have NOT seen the problem you describe. I HAVE noticed that a USB 2.0 disk connected to the hub dropped back to USB 2.0 at some point. I dismounted, unplugged, un-powered the hub and disk drive, then connected everything back up. The problem was gone and hasn't come back yet.
     

Share This Page