Ut: Goty

Discussion in 'Mac and PC Games' started by zao8350, Mar 22, 2010.

  1. zao8350 macrumors regular

    Joined:
    Jul 2, 2009
    #1
    hey, i bought that unreal pack on steam that was on sale during december. I just got around to starting up UT: GOTY the other day and it runs abysmally slow. I have the MBP with the 512mb 9600m gt and 2.8ghz cpu. Any idea what the deal is? i remember playing it on mac with an 800ghz emac and getting better performance. the speed kind of... comes and goes. it swells and such. anything? thanks
     
  2. Dagless macrumors Core

    Dagless

    Joined:
    Jan 18, 2005
    Location:
    Fighting to stay in the EU
    #2
    I've heard theres some weird performance issues on multicore processors, try disabling a core to the game (when it's loaded up bring up the task manager, right click on the game and only enable 1 core for it). It might work, it might now. FWIW I've got a 2006 iMac dual core and I've never had this problem.
     
  3. zao8350 thread starter macrumors regular

    Joined:
    Jul 2, 2009
    #3
    thanks for the response!
    i'm having trouble finding where i can change how many cores it can use. i open task manager and there are a lot of options when i right click unreal, but none say anything about cores. can you provide me with a path for that? thanks
     
  4. Dagless macrumors Core

    Dagless

    Joined:
    Jan 18, 2005
    Location:
    Fighting to stay in the EU
    #4
    Right click on the app/game in the Process tab and select "Set Affinity". Set it to 1 core. Just don't set it to "and beyond!".
     
  5. zao8350 thread starter macrumors regular

    Joined:
    Jul 2, 2009
    #5
    thanks!
    unfortunately i had no "and beyond" button. that must only be for quad cores :)
    also unfortunately, that did nothing for me. it was a good thought though. i made a topic on the steam forums to see if i could get help there. it really makes no sense that this wouldn't work. i may just try redownloading later since it is such a small file.
     
  6. Dagless macrumors Core

    Dagless

    Joined:
    Jan 18, 2005
    Location:
    Fighting to stay in the EU
    #6
    Ah bugger!
    How are other games though? I'm tempted to say it could be a driver problem. Are you running in hardware or software mode?
     
  7. zao8350 thread starter macrumors regular

    Joined:
    Jul 2, 2009
    #7
    well unreal worked great, i played that for about half an hour. haven't played ut2004. unreal 2 ran flawlessly, as does UT3. i'm not sure what it is.
     
  8. yukio macrumors regular

    Joined:
    Feb 8, 2008
    #8
    i run all of the unreal series fine on my bootcamp half and my MBP is slower than yours.

    have you added all of the apps to the exceptions list of the windows firewall?

    also, go into steam settings and uncheck the box for "display promotions" - that bunged my UT every time it would pop up behind the game.
     
  9. zao8350 thread starter macrumors regular

    Joined:
    Jul 2, 2009
    #9
    thanks yukio. I have not, i'll do that once I finish this english paper.

    yeah, it bothers me that i can run UT3 flawlessly on relatively high settings but can't get UT to work. i'll let you know if it works
     
  10. zao8350 thread starter macrumors regular

    Joined:
    Jul 2, 2009
    #10
    i have my firewall set up right. where is this display promotions thing? like, allow steam in game?
     
  11. socamx macrumors 6502

    Joined:
    Oct 7, 2004
    #11
    UT GOTYE and all Unreal 1 engine based games are grossly incompatible with processors that use technology like SpeedStep to adjust CPU speed depending on load. They also have issues with multi-core processors.

    Once the FPS goes over 300, the game either runs too fast, or runs too slow.


    A fix I have found that works is here. This is a modified game launcher for the games which is provided at the bottom. It uses a little bit of code voodoo to make the games based on the Unreal 1 engine play nice with SpeedStep CPUs and multi-core CPUs.

    http://coding.hanfling.de/launch/

    It should be pretty easy to install and setup. However, I never tested it online so I don't know if anti-cheat modifications are going to boot you for it.

    Give it a try and see what's what. You can always just uninstall it.


    I use the Deus Ex launcher and it works perfectly, but I've also tried the UT one with success as well.


    Edit: I forgot to mention, this is a Windows only fix. There is however no reason it shouldn't work with WINE, Crossover, virtualization applications, modified Mac Cider launcher and such.
     
  12. zao8350 thread starter macrumors regular

    Joined:
    Jul 2, 2009
    #12
    ah thank you! this sounds like it should work. hopefully it will do the trick, even with steam and everything will be good to go. I'll let you know how it works
     
  13. socamx macrumors 6502

    Joined:
    Oct 7, 2004
    #13
    I bought Deus Ex through Steam and it works fine. My only guess is that if you attempt to validate the game files, Steam will replace the fixed game launcher with the old one.

    You might want to tell Steam to not fiddle with UT's files. Right click it in the game list and go through the properties and tell it to not keep it up to date. It's not like Epic is going to be releasing a patch for a 11 year old game anytime soon anyway.


    Another thing you may want to do, is update the renderers to either an enhanced OpenGL renderer or DirectX 8/9 renderer, which is found here. The stock renderer for UT is DX7, and a very out of a date OpenGL that barely functions.

    http://www.cwdohnal.com/utglr/

    I use the enhanced OpenGL one for both Deus Ex and UT.
     
  14. zao8350 thread starter macrumors regular

    Joined:
    Jul 2, 2009
    #14
    thanks! my night is open so I'll see if this all works. the directx might be the problem, I think everytime you install an unreal game it asks you to do something with directx and after 5 times I know I didn't click yes for UT. hopefully I'll be fragging like I did in 4th grade computer class soon!
     
  15. socamx macrumors 6502

    Joined:
    Oct 7, 2004
    #15
    In my experience upgrading the OpenGL or DirectX doesn't fix the slowness or fastness. Some people say limiting the FPS or forcing V-Sync on works, but it just made my problems worse.

    The upgraded renderers do however let you have more fine-tuned control over graphical settings and lets you take advantage of certain features such as the high resolution S3TC textures. So the updated launcher coupled with an updated renderer is the best experience you can have in these old Unreal Engine games.

    Let me know if the updated launcher works alright. Like I mentioned, I had success with it on two games now.
     
  16. zao8350 thread starter macrumors regular

    Joined:
    Jul 2, 2009
    #16
    i'm not going to lie, i have no idea how to do the library thing. the instructions aren't doing much for me. i did find a fix, i switched from 3d graphics to the games graphics renderer or something (makes the resolution a little crappier, almost grainy) and it works like a charm. i'm going to keep it like this unless someone wants to explain the other method. thanks for the help guys!
     
  17. socamx macrumors 6502

    Joined:
    Oct 7, 2004
    #17
    Look at the bottom of the page for this part, these are the files you should download. I should have mentioned that. Click the link that says '[Binary]'. No extra work is required besides running the installer.


    Using the software renderer is an extreme downgrade and makes it not even worth playing the game.
     

Share This Page