UT99 (GOTY) on BootCamp

Discussion in 'Mac and PC Games' started by Hobbes-22, Mar 21, 2008.

  1. Hobbes-22 macrumors newbie

    Joined:
    Mar 21, 2008
    #1
    Hello All,

    I am trying to get UT99 (GOTY) to work in BootCamp. It runs, but is waaaaaay to fast to play, Is there anyone out there that has gotten it to work.

    System = iMac 24" 2.4Ghz dual core Intel. This is the new Aluminum style.
    Video = ATI HD 2600 (XT)
    Ram = 4Gigs

    Thanks.
     
  2. tominated macrumors 68000

    tominated

    Joined:
    Jul 7, 2006
    Location:
    Queensland, Australia
    #2
    go into the settings and you should be able to find a game speed slider in the gameplay tab
     
  3. CavemanUK macrumors 6502

    CavemanUK

    Joined:
    Jun 29, 2006
    Location:
    Rhyl, North Wales
    #3
    This is because of the 2 cpu cores. Its quite easy to fix but im not at a windows pc so i cant tell you the exact method.. but basically there are 2 ways to fix it.

    1st way is to run the game, alt+tab back to windows and bring up task manager. from here find unrealtournament.exe and right click on it. a menu should appear and in there is something that lets you untick one of the processors. The down side is you would have to do this every time you run it.

    The 2nd and better way is to get a game launcher. I cant remember the exact name but i remember a launcher called something like win2000launcher or something. Best to do a search for launcher and ut99 or something. The launcher will give you the option of how many cpu cores you want to run.

    Hope this helps.
     
  4. eXan macrumors 601

    eXan

    Joined:
    Jan 10, 2005
    Location:
    Russia
    #4
    How can having more than 1 core affect the game speed ?_?_?

    I never had such issues on my Macs or on my friends' PCs
     
  5. Hobbes-22 thread starter macrumors newbie

    Joined:
    Mar 21, 2008
    #5
    Thanks all for the info...

    Thanks CavemanUK you Rock...It worked. :) ran nice and smooth online, back to fraggin the innocent
     
  6. bstreiff macrumors regular

    Joined:
    Feb 14, 2008
    Location:
    Austin, TX, USA
    #6
    I had it happen on my old single-core Pentium M Vaio. It's not because of two cores, it's because of CPU frequency scaling.

    Basically, UT99 initializes some timer based on the processor speed when you start up. The problem is that the CPU's on low-power mode at that point-- once the UT engine gets good and ready, CPU utilization goes up to 100%, and the processor speed gets scaled up. Now this timer is calibrated incorrectly-- it's set for a processor that's half the speed (in my case, the jump was from 600MHz to 1.6GHz.)

    The Vaio had a driver for configurable power profiles, in which you could force the processor into low-power or high-power mode rather than use automatic scaling; I used that to fix the processor speed before playing.
     

Share This Page