Variant of Logitech LCC Eating Leopard

Discussion in 'macOS' started by Makosuke, Oct 31, 2007.

  1. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #1
    I'm posting this in the hopes that someone searching for the same issue I had will find it and it'll help them.

    There's already the broader "Bluescreen" thread on this topic, but I ran into what at least seems to be a variant of Logitech's Control Center driver package killing Leopard.

    I carefully prepped my MBP for Leopard, but had forgotten that I'd installed LCC a while back to use my desktop Logitech mouse temporarily. I'd removed the prefpane, but it was still launching the daemon via Login Items.

    Now, surprisingly enough, this DIDN'T kill Leopard--it installed and ran fine. But then I noticed that it was launching the daemon, and wanted to make sure everything was uninstalled. Except I hadn't saved the installer for that version, so no uninstaller was available.

    Ok, I'll just go grab the most recent one... which doesn't include an uninstaller. Oh well, I think, I'll just upgrade with that then uninstall IT instead.

    Except when I installed LCC (2.3.1) and restarted as required, Leopard wouldn't boot. This was NOT the bluescreen bug--it would sit at the grey spinner for a couple minutes, then restart, and repeat endlessly. Looking at the verbose mode, it was stalling during initializing bluetooth for some reason.

    What makes this different is that I couldn't find any Unsanity stuff installed, and removing everything I could find via single user mode didn't help, and I kept getting an unfixable error on fsck. Finally, I ran TechTool Pro on the drive, let it fix some directory stuff, and THEN it would boot.

    At that point (thanks to the web) I knew to look for the Logitech uninstaller app in /Library/Application Support/ (which is ridiculous since they don't TELL you that's where it is), I uninstalled it, and all was well.

    I would think that the disk corruption was unrelated, except I'd restarted several times (installing drivers for other things) and it worked fine. I'm assuming that LCC caused a crash on the next reboot, which then caused corruption that prevented a boot even when LCC stuff was manually removed. Could be a bizarre coincidence, but given the other problems I've had with LCC, I'm not so sure.

    Bottom line is that even if your problem is "hanging at the spinner" rather than "blue screen at boot", it might still be LCC related. Second, if removing the LCC stuff via terminal doesn't work, try doing a disk check with something other than fsck. Further, if you need to find the uninstaller and it's not in /Library/Application Support you should probably dig around in the installer package for it rather than upgrading and uninstalling--hopefully, anyway, that will work.


    On an unrelated note, I love Logitech's hardware, but I refuse to buy anything else from them, since (though I'm not averse to 3rd party drivers) Logitech's Mac drivers are so willfully bad (HOW many years did it take them to fix the "ridiculous pointer speed on every reboot" bug?) I refuse to support them.
     
  2. /dev/toaster macrumors 68020

    /dev/toaster

    Joined:
    Feb 23, 2006
    Location:
    San Francisco, CA
    #2
    After the BS that is LCC, I have also ceased purchasing anymore Logitech equipment. Not only do they refuse to fix the problem, they keep blaming my machine. (Which we all know is a total lie, its bad drivers)

    I have called them a few times and they claim that this is the first they are hearing about it, yet their messageboard has tons of complaints.

    If Logitech doesn't want to support Mac, then fine. But, they need to stop leading people to believe their drivers actually work.
     
  3. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #3
    Once again, I've never had any problems with LCC. I guess my Macs are lucky.

    I don't think I'll be deploying it with Leopard though.
     
  4. dr_lha macrumors 68000

    Joined:
    Oct 8, 2003
    #4
    The problem with LCC is that it installs APE. APE is what's causing the "Blue Screen" issue.
     
  5. Makosuke thread starter macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #5
    Well, it'd be more accurate to say that ONE problem with LCC is that it installs APE. As I said, my issue was different--it was a pre-blue-screen restart, not the blue screen stall.

    Actually, I'm a little confused as to why I could NOT find any remnants of APE on my system--I checked all the locations where APE is supposed to put stuff and found nothing at all--does the most recent (and, I guess, older) version of LCC not use it, or are they renaming components now?

    Also, I note that regardless of Leopard bugs, the fact is that LCC has been consistently buggy for YEARS (at the very least since I got my first--and probably last--Logitech mouse 3 years back). I can think of at least one common, stupid, totally reproducible bug that affected me and went unfixed for at least two years. There are other issues I know others routinely have, and then there's the fact that LCC doesn't even support all of their products.

    Not to say that EVERYBODY has problems with LCC--some of course don't--but it is a very problematic driver to put it gently.
     

Share This Page