Various application issues on 1.1.3, gpSPhone

Discussion in 'Jailbreaks and iOS Hacks' started by GFLPraxis, Mar 2, 2008.

  1. GFLPraxis macrumors 604

    GFLPraxis

    Joined:
    Mar 17, 2004
    #1
    Hi guys,
    I got an off-the-shelf 16 GB 1.1.3 iPhone and hacked it with ZiPhone last week. I'm having some trouble with a couple of apps.

    I posted about my iPhysics problems here:

    http://forums.macrumors.com/showthread.php?p=5080207&posted=1#post5080207

    Apps like PocketGuitar also just crash on launch. I don't care too much about it, but gpSPhone is giving me the oddest problems.

    Before I go into it, let me say that I am not a pirate. I even avoid rom sites- I have my own hardware to rip GBA roms and I do not upload them to the internet. I have legal backups here, and even back up the savegames off of my cartridge.

    I can't get gpSPhone 1.2 working despite reports that it runs on 1.1.3 firmware. When I launch the app, it tells me to "Upload roms to /var/root/Media/ROMs/GBA". I have uploaded the roms there and copied them to "/var/mobile/Media/ROMs/GBA" just to be sure. Still get the same error.

    If I manually upgrade to 1.5, the application runs fine, but a couple of the roms (the ones I am most interested in playing) run unbearably choppy. Initially, I couldn't save games, but then I changed some folder permissions and it works. However, reports indicate that those specific games ran much better in 1.2 and are now slower in 1.5 and I know someone who says they run great and he's got an older version. So I'd like to get 1.2 running.

    Any suggestions?
     
  2. GFLPraxis thread starter macrumors 604

    GFLPraxis

    Joined:
    Mar 17, 2004
  3. altered7th macrumors newbie

    Joined:
    Mar 17, 2008
    #3
    If you're still working on this...

    I came across your post while trying to solve the same problem. Just figured it out and thought I would share.

    The problem is that the app runs as user: mobile, but expects to be able to access roms in the /var/root/Media...

    Set all directories leading to the roms to permission 755 and the roms themselves to 644. that should solve your problem.

    You didn't mention it in your post but I assume you know that you also need the bios dump file for the GBA. It must be placed in the folder /Applications/gpsPhone.app/.

    Most of the problems with apps running under 1.1.3/4 seem to stem from that user change issue. Hopefully most apps will get updated soon.
     
  4. dc5wannabe macrumors newbie

    Joined:
    Feb 13, 2008
    #4
    I notice the same thing on my gba and nes emulators. Every few seconds or so, the sound seems to cut in and out and can get kind of choppy at time to time. Is there a solution to this, or is this pretty common for these emulators.
     

Share This Page