Various graphics problems

Discussion in 'OS X Mavericks (10.9)' started by jbios4, Oct 28, 2013.

  1. jbios4 macrumors newbie

    Joined:
    Oct 28, 2013
    #1
    After upgrading to 10.9, I've been seeing some horrible graphics glitches in the shadow backdrops of pretty much all my windows. Here are some screenshots:

    http://i.imgur.com/OhvXEUq.png
    http://i.imgur.com/DBOOvFL.png
    http://i.imgur.com/j4B1yjm.png

    A reboot temporarily fixes it, but it comes back the next morning. I'm using a MBP from early 2010 with the 520m i5 and an nVidia 320m and Intel HD graphics. Before this, I was running 10.7 for a couple years with no troubles.

    Any help would be appreciated.
     
  2. coldwaves macrumors regular

    Joined:
    May 30, 2011
    #2
    I don't have this problem after updating to Mavericks. I did a clean installation. Have you tried resetting PRAM? I had breaking images when connected to a cinema display when I upgraded to Mountain Lion a while ago and a PRAM resetting fixed the problem. I am not sure whether this will work but it might worth a try since it is pretty simple.
     
  3. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #3
    I don't have this issue exactly. My screen simply stays black after waking from sleep on my MBPr. Simply bringing up windows clears it up, but it is annoying.
     
  4. jbios4 thread starter macrumors newbie

    Joined:
    Oct 28, 2013
    #4
    I'll try this the next time it happens. Any other ideas/experiences welcome.
     
  5. JCPH macrumors member

    Joined:
    Aug 11, 2007
    Location:
    Tannhäuser Gate
    #5
    I've been having similar graphics problems since updating to Mavericks. Reseting the NVRAM did not solve it. Turning off automatic graphics switching seems to fix it, though this is obviously not ideal.
     

Share This Page