Verification Failed Again and Again and Again

Discussion in 'Mac Basics and Help' started by andorrak, May 15, 2010.

  1. andorrak macrumors newbie

    Joined:
    Nov 25, 2009
    #1
    I continue to get verification failed every time I try to download anything when it is nearing its end.

    It is very frustrating.

    What the hell is happening. Tried fixing permissions didn't do anything.

    Don't know what to do.
     
  2. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #2
    Never seen that before. What program are you using to download? What kind of files are you downloading? Where are you downloading them from?
     
  3. andorrak thread starter macrumors newbie

    Joined:
    Nov 25, 2009
    #3
    trying to download from websites.

    torrents work and mac updates work.

    But trying to download from anything like game sites or music sites, etc.
     
  4. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #4
    Okay, I imagine that you're using torrent software for the torrents and if for Mac Updates, you mean Software Update then that's built in to the OS, so I'm guessing that the problem with the game and music sites may be related to the browser you're using. Have you tried a different browser?
     
  5. alex.roy macrumors newbie

    Joined:
    Mar 5, 2008
    #5
    im having the same problems as well. running 10.6.3, Safari 5. the programs i download either stop throughout the download or when finished downloading, will not mount due to verification failure.

    any updates on a fix?
     
  6. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #6
    It's just as likely that the problem is with the disk mounter as the download itself if things other than DMG files download and mount ok (from the date it looks like the OP isn't going to need any more help, so just going off of alex.roy's question). If torrents and software update work, then your network is basically ok, and neither of those result in disk images, so they would bypass the verification/mount step.

    Downloading an application contained in a .zip instead of a DMG would be one way to test--if it downloads and runs, then that's a good sign that it's the .dmg mount process at issue. I'm also assuming here that if you download something with Firefox you have the same issue, or is that ok?

    I once had this happen to me (failure to mount DMGs), but a reboot cleared it up. You could try booting from the OS install disc and checking your hard drive for errors using Disk Utility and repairing permissions, to see if either helps. Also try creating a new user account, and see if DMGs work there.

    I'd normally suggest downloading and reinstalling the Combo updater for either 10.5.8 or 10.6.4 (depending on which OS you're running), on the off chance it would help, but that's not going to be easy if you can't mount DMGs.
     

Share This Page