"Verification Failed" When Trying to Log In to iCloud

Discussion in 'iOS 10' started by ghall, Feb 16, 2017.

  1. ghall macrumors 68040

    ghall

    Joined:
    Jun 27, 2006
    Location:
    Rhode Island
    #1
    Sorry for the long post, but there's a lot to my issue.

    Earlier this evening I was trying to use Apple Pay, but it kept prompting me for my Apple ID password. I entered it and it said "Verification Failed Please Try Again". Ended up just paying with my regular card, but I was worried somebody might have gained access to my account so I reset the password. Logged in on my Mac with the new password, no problem. Logged into my iPad with the new password, it struggled for a bit and eventually worked. My iPhone though still insisted on "Verification Failed". So I went online and found some solutions, like resetting network settings and then I thought to restore the phone. Couldn't do that because it wouldn't accept my password to turn off Find My iPhone. Well, I eventually was able to get it backed up to iTunes and I did a remote wipe via icloud.com. Restored the backup and now it's just constantly asking me to enter my password, repeating that "verification failed".

    What are my options?
     
  2. themoonisdown09 macrumors 601

    themoonisdown09

    Joined:
    Nov 19, 2007
    Location:
    Georgia, USA
    #2
    I'm having the same issues with my iPhone that I've had since October 2015. I started having this issue after I bought an AppleTV tonight and couldn't sign into iCloud with it. Tried it on my iPhone and that didn't work either. It works just fine on my iMac and my MacBook Pro as well as on iCloud.com.

    I tried turning off 2-Factor authentication as well as changing my password, and neither of those helped me on the iPhone or AppleTV. It works still on my iMac and MacBook Pro.
     
  3. themoonisdown09 macrumors 601

    themoonisdown09

    Joined:
    Nov 19, 2007
    Location:
    Georgia, USA
    #3
    I tried it again about 20 minutes ago and I'm able to sign in with all my devices now. Must have just been issues with Apple's servers.
     

Share This Page