Verify and Repair Disk Permissions Buttons Grayed / Greyed Out

Discussion in 'macOS' started by ZigZagLens, Jun 9, 2008.

  1. ZigZagLens macrumors member

    May 16, 2007
    I have two 500GB drives in my Mac Pro. The second drive, Drive Two, which I was using as my Time Machine drive, started giving me errors (Time Machine errors) that it could not complete the backup because it could not write to the volume.

    So, I was going to do a verify / repair permissions. But the option on the Drive Two volume is grayed out. I can "verify disk" or "repair disk" no problem (and get no errors). But the verify/repair disk permissions buttons are grayed out.

    I tried booting from the OSX DVD and the Disk Utility did the same thing. I can verify / repair disk permissions on the boot drive (Drive One) with no problems. But not on Drive Two.

    Also when I do a "get info" on that Drive Two volume (inside the Disk Utility) I see this pesky little thing in the infobox:

    Owners Enabled : Yes
    Can Turn Owners Off : Yes
    Can Repair Permissions : No
    Can Be Verified : Yes
    Can Be Repaired : Yes
    Can Be Formatted : Yes
    Bootable : Yes
    Supports Journaling : Yes
    Journaled : Yes
    Disk Number : 1
    Partition Number : 2

    I can't figure out why this is. Any ideas?

    I've already tried cleaning the drive entirely, deleting the partition, re-creating the partition and re-formatting. Same issue.


    Mac Pro 2x2.66 DC Xeon
    5GB RAM
  2. nightfly13 macrumors 6502a


    Jul 17, 2008
    Ranchi, India
    I know the answer is comically late, but maybe it'll help someone else. Apparently you can only repair permissions on the boot drive.
  3. Macman45 macrumors G5


    Jul 29, 2011
    Somewhere Back In The Long Ago
    I Haven't Tried Myself

    But I wonder if Onyx will allow you to verify and repair permissions on that drive? It's free, but be careful with it if you are not familiar with it's higher end functions

Share This Page