Verify disk permission wiped my files

Discussion in 'Mac Basics and Help' started by anarchyinwa, Dec 8, 2010.

  1. anarchyinwa macrumors newbie

    Joined:
    Sep 7, 2010
    #1
    Hi, sort of freaking out a bit... I was having a few issues with a LaCie d2 2TB drive that I'm using (formatted NTFS using Paragon NTFS)... namely disc image files were "not recognized"... so I tried restoring the permissions on the drive and that made all the files disappear...

    According to the Finder there are zero files on the drive but 1.7TB has been used. So my stuff (which is quite important and - surprise - I have no back up of) appears to be there but how do I get it back? I'm on a MacBook Pro (late 2008) with OS X 10.6.3.

    Any ideas?

    Cheers.
    Will
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    To start with, you can only use Disk Utility to verify/repair permissions on a boot drive (it's greyed out for any other volume), so you were actually running it on your OS disk, not the NTFS external, or you were running a directory verify/repair, not a permissions one. Second, Verify does just that--it doesn't alter any data--so your data disappearing was apparently a coincidence, unless you also tried to run "Repair Disk" at the same time as the permissions repair (or you accidentally clicked "Repair Disk" instead of "Repair Disk Permissions").

    As for what to do, I'd frankly start by finding a Windows box and checking it from there--I've never used it much myself, but I've heard a few stories about the 3rd party NTFS write drivers for OSX causing corruption on occasion, so giving the disk to a system with more robust NTFS support is the safest step. From Windows, if you can't see the files, it's time to try either repairing the directory or running a recovery program.

    You could try running a disk check, but that could end up replacing the damaged directory with a nice "correct" one that includes no files at all. A better idea would be to get yourself a copy of Data Rescue 3 for Windows and see what it finds--there's a Mac version of Data Rescue 3, but I don't believe it supports NTFS, while the Windows version definitely does. If my experience with the app is any indication, if there are files to be salvaged, Data Rescue will salvage them.
     

Share This Page