Verify disk shows errors - disk repair shows none

Discussion in 'Mac Basics and Help' started by davewilkinson, Apr 20, 2008.

  1. davewilkinson macrumors newbie

    Joined:
    Apr 20, 2008
    #1
    I was trying to set up Boot Camp on my mbp, and got an error when trying to partition the drive. I ran a verify disk command from the disk utility and it showed minor errors. So I ran the disk utility from the install DVD (disc1) and fixed the error. But when I restart and run verify again I still get errors.

    I've done this 3 or 4 times now but I'm still getting the same errors. Any suggestions?
     
  2. catachip macrumors regular

    catachip

    Joined:
    Jun 7, 2007
    Location:
    Vancouver, British Columbia
    #2
    First, try running disk repair from single user mode. Restart the Mac and hold down the Command (Apple) Key and letter "S" simultaneously. You'll be dumped into a unix command prompt. Type in the following and press return:

    fsck -fy

    If you get a response that is anything but "OK" for each item, then run the command again. Try running boot camp again after that.

    If it still doesn't work, you may need to invest in a more thorough disk utility. Do you have AppleCare? There is a utility called Tech Tool Pro on the disk that will check all components of the computer, including a complete check of the entire disk.
     
  3. davewilkinson thread starter macrumors newbie

    Joined:
    Apr 20, 2008
    #3
    Thanks very much for your help. Errors repaired and Boot Camp installed.
     

Share This Page