Verizon-- Fails to auto connect LTE

Discussion in 'iPhone' started by Trey M, Jan 4, 2016.

  1. Trey M, Jan 4, 2016
    Last edited: Jan 4, 2016

    Trey M macrumors 6502a

    Trey M

    Joined:
    Jul 25, 2011
    Location:
    USA
    #1
    Hi all,

    I have a 6s+ on Verizon, and I've noticed that when I go into an area with not-great reception, my phone will stay connected to 3G. A lot of times it will remain on 3G for 10+ minutes until it finally realizes LTE coverage is available. Almost every time I notice my phone on 3G, I toggle airplane mode on/off, and every time it comes back up connecting to LTE.

    I realize this is a quick fix, but it seems pretty stupid my phone isn't smart enough to connect to the LTE network. At both my home and office, I have mediocre Verizon coverage (usually 2 bars). At both places, they can always receive LTE coverage, but a lot of times it requires this airplane mode toggle. Anyone else experiencing these issues as well?

    One note to add: when connected to 3G, the Internet connection is hardly useable. It's not what you'd expect of 3G speeds. Which adds even more frustration knowing LTE IS available.
     
  2. rzc16512 macrumors regular

    Joined:
    Jun 3, 2015
    #2
    Try doing setting -> general -> reset -> reset network settings . This will erase all wi-fi passwords if iCloud Keychain is not enabled. If that doesn't work maybe removing and re-inserting the SIM card.
     
  3. shreff86 macrumors member

    Joined:
    Mar 16, 2015
    #3
    I have the same issues as you have described with it hanging in 3G it's very frustrating some apps won't even load
     
  4. Erdbeertorte macrumors demi-goddess

    Erdbeertorte

    Joined:
    May 20, 2015
    Location:
    Castle Grayskull, Eternia

Share This Page