Verizon iPhone 4 Messaging Problems

Discussion in 'iPhone Tips, Help and Troubleshooting' started by filmbuff, Jun 24, 2013.

  1. filmbuff macrumors 6502a

    filmbuff

    Joined:
    Jan 5, 2011
    #1
    I'm about 6 months into a 2 year contract with my iPhone 4. I got Verizon because the coverage here is decent and it was $5 cheaper than AT&T.

    There is a very annoying problem that's been happening a lot recently. My phone will randomly fail to send or receive text messages. When they fail to send I will get the blue loading bar across the top of the messaging app and after it sticks there for a while it will eventually say failed to send and show the red icon next to the messages.

    The failure to receive is a little more insidious because it won't do anything. Somebody will say, "how come you never replied to my text yesterday?" and I look and have no texts from that person. But their phone says delivered so it was definitely sent.

    This seems to happen regardless of what type of service I have. Usually in town I have at least 4 bars and a solid 3g signal. Is this a problem with the network? Is it something Verizon can fix if I take it in? I need to be able to send and receive texts for work so this is sort of a big problem.
     
  2. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #2
    sounds like a network issue. this happened to my wifes phone last week. for me it shows sent as text but for her she said shes getting them as imessages. i had her to a heard reboot and it hasnt been an issue since.

    also in the imessage settings, make sure "send as sms" is turned on. that way, if imessage fails, it will send it as a text eventually when the imessage times out its failed attempts. takes like 5 minutes or so, but it will deliver since sms is very reliable.
     
  3. filmbuff thread starter macrumors 6502a

    filmbuff

    Joined:
    Jan 5, 2011
    #3
    I should be clear I'm talking about SMS text messages.

    I just tried to send one to two people at the same time and I got an error/could not send. I tried 3-4 times to resend the message and it didn't work. Then I tried an individual text to one of the people and it worked perfectly. This is beginnin to work my nerves.
     
  4. le3x macrumors newbie

    Joined:
    Jun 19, 2013
    #4
    Try to reset the network settings. Also, have you installed any cydia tweaks for messages or phone? This may be the reason.
     

Share This Page