Verizon iPhone GPS issue

Discussion in 'iPhone Tips, Help and Troubleshooting' started by chrissss, Jul 11, 2011.

  1. chrissss macrumors newbie

    Joined:
    Jul 11, 2011
    #1
    Hey all, new here

    Came from a HTC EVO on Sprint

    Now using a white Verizon iPhone 4
    So far, so good...except for one thing

    I do a lot of cycling and would always use Runkeeper (www.runkeeper.com) to track and record my rides on my EVO and it worked great for the most part. Never gave me any real troubles.

    Fast forward to getting the iPhone.
    Waited until I had a strong GPS lock according to the app and went for a ride.
    Almost right away I knew something was up. Turned it off and tried again. Still not right.
    Got home and did a restore. Still not right.
    Tried a different app (MapMyRide) same issues only worse.

    Here is what the apps are giving me

    Runkeeper (this was a "good" one)
    [​IMG]

    MapMyRide:
    [​IMG]

    This is what they should look like (not cutting across the middle):
    [​IMG]


    Is this normal for the iPhone?
    Should I take it to Apple?
    Any other help is appreciated
     
  2. chrissss thread starter macrumors newbie

    Joined:
    Jul 11, 2011
  3. TraceyS/FL macrumors 68040

    Joined:
    Jan 11, 2007
    Location:
    North Central Florida
    #3
    I downloaded this this morning to try out for you - I was curious because it was so strange! I did it driving in the car though, and just for like 5 miles. It was dead on on following the road and nothing strange. If i remember i will turn it on tomorrow when I'm driving around town in more of a circle and see what it does.

    Have you checked with run keepers support?

    Have you tried using something else that uses maps or tracks you? DD used maps today when we were in the middle of nowhere and it was pretty accurate.

    I wish I could be of more help.

    (fyi, My Verizon iPhone is just 2 weeks old)
     

Share This Page